View unanswered posts | View active topics It is currently Sat May 25, 2019 8:59 pm






Reply to topic  [ 7 posts ] 
ROBOTC - Version 4.25 observations 
Author Message
Rookie

Joined: Thu Aug 14, 2014 12:30 pm
Posts: 2
Post ROBOTC - Version 4.25 observations
I downloaded version 4.25 and tried a few graphical and natural language programs that I had previously written for the Summer Course challenges. I am finding that the programs are not running as they did under version 4.10. Particularly noticed that the timer and motor encoder commands were not longer functioning in the same manner.

I went as far as instruct the program to if the motor encoder was greater than 100 milliseconds and the robot still ran for several seconds until it ran off the 'table'. I did similar trials with the motor encoder command.

Is there a way to go back to version 4.10 ? What other remedies are possible ?


Sat Aug 16, 2014 12:21 am
Profile
Moderator
Moderator

Joined: Mon Oct 04, 2010 2:18 pm
Posts: 196
Post Re: ROBOTC - Version 4.25 observations
Hello,

I'm not sure what you mean when you say "I went as far as instruct the program to if the motor encoder was greater than 100 milliseconds". Can you clarify please? Thanks,


Sun Aug 17, 2014 6:43 pm
Profile
Rookie

Joined: Thu Aug 14, 2014 12:30 pm
Posts: 2
Post Re: ROBOTC - Version 4.25 observations
I just saw the typo in my message. I meant to write that the robot was instructed to proceed in a direction until the timer was greater than 100 milliseconds (the timer was initially reset). The robot continued for several seconds until it ran off the table.

I also used a motor encoder instruction so that the robot would only proceed in a direction until the motor encoder reached a relatively small number (the motor encoder was initially reset). Again, the robot continued for much longer until it ran off the table (I had the debugging window open).


Sun Aug 17, 2014 7:41 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Jun 11, 2014 9:59 am
Posts: 115
Post Re: ROBOTC - Version 4.25 observations
Rookie2014,

I am trying to replicate the problem that is occurring. I was wondering if you could give me a little bit more information to help me fully understand what is going on.
Could you please attach:
1) A picture of your code or convert it to text and copy it onto the forum
2) A picture of your motors and sensors setup

Thanks, Lee


Mon Aug 18, 2014 2:38 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Jun 11, 2014 9:59 am
Posts: 115
Post Re: ROBOTC - Version 4.25 observations
Rookie2014,

We are aware of this issue, and we are currently working on a solution.
Thank you for your patients.

Thanks, Lee


Mon Aug 18, 2014 4:42 pm
Profile
Rookie

Joined: Sat Jun 21, 2014 12:30 pm
Posts: 8
Post Re: ROBOTC - Version 4.25 observations
I am having similar problems with the Obstacle Detection challenge using the 4.25 version of RobotC. Here is my code. The robot senses the obstacle and stops. When the obstacle is removed it continues moving forward until it hits the wall and tries to go over the edge.

Attachment:
obstacle detection.PNG
obstacle detection.PNG [ 22.49 KiB | Viewed 6194 times ]


Mon Aug 18, 2014 6:41 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Wed Jun 11, 2014 9:59 am
Posts: 115
Post Re: ROBOTC - Version 4.25 observations
rustY1023,

There is an issue with the motor encoders. We are currently working on a solution.

Thanks, Lee


Tue Aug 19, 2014 9:22 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.