View unanswered posts | View active topics It is currently Sat Oct 25, 2014 11:44 pm






Reply to topic  [ 4 posts ] 
Robot C program does not run with VEXNET (HELP!) 
Author Message
Rookie

Joined: Sun Oct 11, 2009 7:01 pm
Posts: 4
Post Robot C program does not run with VEXNET (HELP!)
I just recieved a vexnet kit and have installed the hardware on the microcontroller. I've downloaded both the IFI Master Firmware V8 and the RobotC vex firmware.

I opened a competition template file and added

motor[port1]=vexRT[Ch3];
motor[port2]=vexRT[Ch2];

under the section task usercontrol(). I complied and downloaded the program sucessfully but nothing happens. The VEXnet lights both say the robot and the VEXnet signal is okay but I am not able to control the robot at all.

When I just create a new file and download the following instead, it works.

task main ()
{
while (true)
{
motor[port1]= vexRT[Ch2];
motor[port2]= vexRT[Ch3];
}
}

Why does the competition template not work?!

Thanks :)


Sun Oct 11, 2009 7:08 pm
Profile
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 613
Post Re: Robot C program does not run with VEXNET (HELP!)
Please see this thread:
viewtopic.php?f=11&t=1877

Also, try these new competition templates. We're working on incorporating these into the new release as well:
Attachment:
Vex_Competition_Includes.c [5.61 KiB]
Downloaded 344 times

For this one, make sure you copy it to the "C:/Program Files/Robotics Academy/ROBOTC for IFI/templates" folder
Attachment:
Vex_Competition_Template.c [2.57 KiB]
Downloaded 332 times

Use this new template to program in. Must have 1.70 or later.

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Tue Oct 13, 2009 12:49 pm
Profile
Rookie

Joined: Sun Oct 11, 2009 7:01 pm
Posts: 4
Post Re: Robot C program does not run with VEXNET (HELP!)
Is there a reason why the competition template.c file must be saved in the template folder? I didn't notice this before so I pasted it on my desktop and it still seemed to work. The include file however, I saved in the Includes folder.


Thu Oct 22, 2009 3:05 pm
Profile
Rookie

Joined: Fri Oct 09, 2009 9:21 am
Posts: 28
Post Re: Robot C program does not run with VEXNET (HELP!)
I think it's so you overwrite the old version and can find it in the menu. It doesn't have to be there to work.

_________________
Jon Thompson
Coach - Twisted Bots
VRC 177


Fri Oct 23, 2009 8:40 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.