View unanswered posts | View active topics It is currently Wed Nov 26, 2014 2:03 pm






Reply to topic  [ 12 posts ] 
My motors wont work 
Author Message
Rookie

Joined: Wed Dec 03, 2008 11:29 am
Posts: 3
Post My motors wont work
Like the subject says. Plain and simple my motors wont work. I have tried everything. I have an nxt brain with the hitechnic motor and servo controler and when i run the scripts nothing works. I have the motor equiped and whenever i try to run any programs nothing works. I've also tried using labview and mindstorms nothing works at all.. Please Can anyone help me.


Wed Dec 03, 2008 11:34 am
Profile
Rookie

Joined: Wed Dec 03, 2008 11:29 am
Posts: 3
Post Re: My motors wont work
Please Help


Wed Dec 03, 2008 11:50 am
Profile
Professor

Joined: Fri Sep 19, 2008 1:22 am
Posts: 200
Post Re: My motors wont work
You have not provided anywhere near enough information for anyone to be able to help you.

Exactly how is your robot wired? For example, which port on the NXT is wired to your motor controller? Are you positive that you have the power wires to and from the motor and servo controllers attached correctly?

What version of RobotC do you have?

Post your code!

_________________
Jeff McBride
Benson Robotics Club


Wed Dec 03, 2008 1:09 pm
Profile
Rookie

Joined: Wed Dec 03, 2008 11:29 am
Posts: 3
Post Re: My motors wont work
i have everything connected correctly. I tested it and i have power going into everthing but i do not have comeing out of the hitechnic motor one but there is power going into it.


Wed Dec 03, 2008 2:36 pm
Profile
Professor

Joined: Fri Sep 19, 2008 1:22 am
Posts: 200
Post Re: My motors wont work
I'm sorry but you need to answer the questions fully if you want to get any kind of meaningful answers.

_________________
Jeff McBride
Benson Robotics Club


Wed Dec 03, 2008 3:29 pm
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3293
Location: Rotterdam, The Netherlands
Post Re: My motors wont work
';,,,;' wrote:
Like the subject says. Plain and simple my motors wont work. I have tried everything. I have an nxt brain with the hitechnic motor and servo controler and when i run the scripts nothing works. I have the motor equiped and whenever i try to run any programs nothing works. I've also tried using labview and mindstorms nothing works at all.. Please Can anyone help me.

Our forum psychics are currently on sabbatical, so unfortunately, you will have to try a little harder to explain what you have done, what code you have written to test the motors and any other details you think will help us determining the root cause of the problem. Otherwise you will get inane questions like: did you put batteries in your NXT brick?

Thanks,
Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Thu Dec 04, 2008 6:21 am
Profile WWW
Moderator
Moderator
User avatar

Joined: Wed Jan 31, 2007 3:39 am
Posts: 299
Location: San Diego, California. USA
Post Re: My motors wont work
Im going to move this to the FTC forum

Scott B-)

_________________
Mmmm Legos B-)

My Robot Projects:
http://www.freewebs.com/robotprojects/


Thu Dec 04, 2008 1:19 pm
Profile WWW
Novice

Joined: Mon Oct 13, 2008 6:29 pm
Posts: 75
Location: Florida, USA
Post Re: My motors wont work
more info plz

_________________
PHUHS Robotics
Team 516 FTW

Daytona Robofest Winning Alliance Captain
Daytona Robofest Inspire Award


Thu Dec 04, 2008 5:25 pm
Profile
Rookie

Joined: Thu Dec 04, 2008 4:40 pm
Posts: 8
Post Re: My motors wont work
Is your NXt turned on? Did you select the right program on the menu to make it run? Does your NXT have batteries? Are the motors connected? Are your motors connected in the correct places? Did you specify the motors in your code? Did you go under robot->motors and sensors in robot c and select motor ports and names? Please post the code you have. Trying to help you will be like trying to find a needle in a metal pin stack if you do not specify. :poke:

_________________
Trying to help you will be like trying to find a worm in the middle of a blizzard. A white worm.


Fri Dec 05, 2008 5:11 pm
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3293
Location: Rotterdam, The Netherlands
Post Re: My motors wont work
I get the feeling that the OP has fixed the problem but neglected to let us know.

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Fri Dec 05, 2008 5:20 pm
Profile WWW
Rookie

Joined: Thu Dec 04, 2008 4:40 pm
Posts: 8
Post Re: My motors wont work
That, or he is embaressed b/c it was something simple. So '....', in the words of another forum poster, I poke you for information. :poke:

_________________
Trying to help you will be like trying to find a worm in the middle of a blizzard. A white worm.


Fri Dec 05, 2008 5:26 pm
Profile
Rookie

Joined: Thu Dec 04, 2008 4:40 pm
Posts: 8
Post Re: My motors wont work
Oh, forgot to ask. Did you press compile and download program? :bigthumb:

_________________
Trying to help you will be like trying to find a worm in the middle of a blizzard. A white worm.


Fri Dec 05, 2008 5:32 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.