View unanswered posts | View active topics It is currently Sat Jul 26, 2014 7:57 am






Reply to topic  [ 9 posts ] 
Brake/Coast Not Working 
Author Message
Rookie

Joined: Thu Oct 09, 2008 8:08 pm
Posts: 2
Post Brake/Coast Not Working
Hello,

We finally got our FTC kit so I get to play with all the bells and whistles of it for a few days.

Though, when I started to play with it, I noticed that I could not set the 12V DC Motors to coast or brake. The line of code below does nothing.
Code:
bFloatDuringInactiveMotorPWM = false;


Is this a bug or am I missing something?

Thanks
-Tanner


Thu Oct 30, 2008 6:48 pm
Profile
Rookie

Joined: Sun Nov 30, 2008 7:34 pm
Posts: 2
Post Re: Brake/Coast Not Working
Hey,

We've been having the exact same problem. Hopefully by bumping the thread there will be a reply.


Sun Nov 30, 2008 11:29 pm
Profile
Rookie

Joined: Thu Dec 04, 2008 4:40 pm
Posts: 8
Post Re: Brake/Coast Not Working
2008FTC3049 wrote:
Hey,

We've been having the exact same problem. Hopefully by bumping the thread there will be a reply.

:breakcomputer:

_________________
Trying to help you will be like trying to find a worm in the middle of a blizzard. A white worm.


Fri Dec 05, 2008 5:54 pm
Profile
Rookie

Joined: Thu Oct 09, 2008 8:08 pm
Posts: 2
Post Re: Brake/Coast Not Working
Glad to know its just not me and not a isolated problem.

-Tanner


Fri Dec 05, 2008 5:56 pm
Profile
Rookie

Joined: Thu Dec 04, 2008 4:40 pm
Posts: 8
Post Re: Brake/Coast Not Working
I know, It makes you feel stupid when it's just you and an isolated problem. Have you had any problems with a servo testbed?

_________________
Trying to help you will be like trying to find a worm in the middle of a blizzard. A white worm.


Fri Dec 05, 2008 5:57 pm
Profile
Novice

Joined: Thu Oct 09, 2008 7:58 pm
Posts: 79
Post Re: Brake/Coast Not Working
We haven't gotten to test any Servos yet, but I have not heard of any problems. :?:


Sun Dec 07, 2008 1:09 pm
Profile
Guru
User avatar

Joined: Sat Mar 01, 2008 12:52 pm
Posts: 1030
Post Re: Brake/Coast Not Working
2008FTC3049 wrote:
Hopefully by bumping the thread there will be a reply.


abandon all hope!
all they'll do is threaten to ban you! :lol:

_________________
regards,
HaWe aka Ford
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;task main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PutPixel(x,y);}}}while(1)}


Sun Dec 07, 2008 2:18 pm
Profile
Novice

Joined: Mon Oct 13, 2008 6:29 pm
Posts: 75
Location: Florida, USA
Post Re: Brake/Coast Not Working
Brake worked great for us, maybe its a bug.

At least this is a reply :bigthumb:

_________________
PHUHS Robotics
Team 516 FTW

Daytona Robofest Winning Alliance Captain
Daytona Robofest Inspire Award


Mon Dec 08, 2008 5:36 pm
Profile
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 601
Post Re: Brake/Coast Not Working
The Brake/Coast variable is meant for NXT motors, not for the FTC motors. The motor controller does not allow us to select "coast/brake" mode, so you'll have to kludge it.

Apply a speed of "1" to get the FTC motor to coast, and a speed of "0" to get the FTC motor to brake.

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Tue Dec 09, 2008 10:45 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.