View unanswered posts | View active topics It is currently Thu Oct 22, 2020 3:02 pm

Reply to topic  [ 2 posts ] 
Help with Mindstorms RCX 2.0 software 
Author Message

Joined: Fri Dec 05, 2014 2:04 pm
Posts: 1
Post Help with Mindstorms RCX 2.0 software
I have installed the software for Lego Mindstorms Robotics Invention System 2.0 onto a laptop running Window 7 32-bit. The first time I opened the software it started to open and run. When it got to the screen telling me that it couldn't find the USB tower, I had to stop. I had to cancel as I had to do something else in my class. When I tried to run it again, it won't open I get a critical error message telling me that I am out of memory or need to reload the software. I have done this twice...uninstalled and reinstalled. I keep getting the same error. I have plenty of room on the laptop as we have set it up for use only with this software. Any suggestions on what is going on with this program. We were able to use it last year with Windows 7 32-bit and had minimal issues. Any idea why the critical error is now coming up instead of the program?


Fri Dec 05, 2014 2:09 pm

Joined: Fri Jan 02, 2015 12:42 pm
Posts: 1
Post Re: Help with Mindstorms RCX 2.0 software
Hi, Hope I can help...
I am getting the same error on my computer running XP when I start the software for a second time.
I had read that this is because a 'temp' file "Ris" is left on the computer after running the programme, which must be deleted before running the programme again, or it will give the "A critical error has occurred. You may be running out of memory, or you may need to reinstall Robotics Invention System 2.0." message... (Apparently you could write a batch file to do this for you, but you'll need to search Google to find out how)
Although lots of people suggested deleting this temp file, I couldn't find it, even after a search!!
I'm writing this in case it helps anyone find the file!
Mine was:
c:\ - Documents and Settings - [yourusername] - Local Settings - Temp - Ris
As I have several usernames, I had to delete each instance of this file under each username.
I didn't need to restart the computer - it just worked when I re-launched the programmme...
Hope it helps!

Fri Jan 02, 2015 1:07 pm
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.