View unanswered posts | View active topics It is currently Thu Nov 27, 2014 7:08 am






Reply to topic  [ 3 posts ] 
Awfull RobotC VW v3.50 performance in VirtualBox 
Author Message
Rookie

Joined: Sat Feb 12, 2011 6:17 pm
Posts: 12
Post Awfull RobotC VW v3.50 performance in VirtualBox
Hi,

I have been using RVW v3.08 in VirtualBox for some time. Robots were not moving fast but my students found this OK for them because general programming in such kind of environment worked (we even implemented PID controller successfully).
When RobotC 3.50 was announced we decided to take a look at new version. And what we can see there is unaccptable performance degradation. VirtualWorlds menu is working very slowly. When the robot is being tried to run it does not move smoothly - 0,5 secs of moving 2 secs of delay.

I see that RVW now is supplied with Curriculum Challange Pack v2.2.3. May it lead to such behaviour? Or it is caused by "Improved Robot Virtual Worlds performance to simulate more realistic physics and robot behaviors"? Can it be fixed through configuration?

Thanks in advacne for your help.


Sun Sep 09, 2012 8:22 am
Profile
Moderator
Moderator
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3293
Location: Rotterdam, The Netherlands
Post Re: Awfull RobotC VW v3.50 performance in VirtualBox
3D performance (including PhysX) in general is really terrible in Virtual Box. There is little to no hardware acceleration, which RVW relies very heavily on. Did you try using VMWare Player 5 (also free, runs on Linux and Windows) to see if that makes a difference?

- Xander

_________________
| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]


Sun Sep 09, 2012 8:39 am
Profile WWW
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:42 am
Posts: 614
Post Re: Awfull RobotC VW v3.50 performance in VirtualBox
Your performance is directly affected by the video card in your computer. Using Virtual Box, your computer is not utilizing any of your graphics power and trying to run the Virtual Worlds engine. Performance is expected to be lower than expected due to the lack of hardware acceleration with the video card.

I would recommend VMWare Player, Parallels Desktop, or VMWare Fusion and a copy of Windows to maximize your performance.

Thanks.

_________________
Timothy Friez
ROBOTC Developer - SW Engineer
tfriez@robotc.net


Tue Sep 11, 2012 5:16 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.