View unanswered posts | View active topics It is currently Sun Apr 20, 2014 12:07 am






Reply to topic  [ 3 posts ] 
Error: no NXT bricks connected via USB (1.10) 
Author Message
Guru
User avatar

Joined: Sat Mar 01, 2008 12:52 pm
Posts: 1030
Post Error: no NXT bricks connected via USB (1.10)
since ashort time ago (30 minutes or so) I can't download any file to my 2 NXT anymore.
"Failed to open Communicatio link to NXT brick.
...
Error Code:
Fantom Err: 'Firmware Download Failed'

Why this?
Nothing severe had occured, everything's like before,
Brick is switched on,
Windows recognizes that NXT is connected via USB (device manager: LEGO MINDSTORMS NXT, USB\VID_0694&PID_0002\0016530119E8)

But RobotC can't find Brick via USB ? ! ?

RobotC deinstalled, rebooted, new installed (v. 1.10): Error remains the same!
Same error with both of my bricks!

EDIT:
Tried do download the original Lego firmware to the NXT:
Not possible,
No bricks detected as well.
Tried to reset 1 of my NXTs:
Display stays empty, NXT "ticks" like a clock,
connecting it via USB: Windows recognizes USB device ("dong-ding"),
but neither Lego nor RobotC get a connection.

What might be the reason?

_________________
regards,
HaWe aka Ford
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;task main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PutPixel(x,y);}}}while(1)}


Fri Mar 21, 2008 12:51 pm
Profile
Guru
User avatar

Joined: Sat Mar 01, 2008 12:52 pm
Posts: 1030
Post 
problem solved:
USB device driver was installed, but had a failure.
new installation of NXT USB Device driver =>
everything's ok!

_________________
regards,
HaWe aka Ford
#define S sqrt(t+2*i*i)<2
#define F(a,b) for(a=0;a<b;++a)
float x,y,r,i,s,j,t,n;task main(){F(y,64){F(x,99){r=i=t=0;s=x/33-2;j=y/32-1;F(n,50&S){t=r*r-i*i;i=2*r*i+j;r=t+s;}if(S){PutPixel(x,y);}}}while(1)}


Fri Mar 21, 2008 2:45 pm
Profile
Novice

Joined: Fri Jan 18, 2008 11:07 pm
Posts: 51
Location: Ohio
Post 
I am also beginning to have USB port problems as well. Last night my Mouse and keyboard stopped working. Both are using USB ports.

I had to finally switch my mouse to a USB port on the front of my CPU to get it to work and it works fine and the port on the back of the CPU is dead.

I just had the same thing happen a few minutes ago, and I again had to switch my keyboard to a port on the front of my CPU.

The first time it happened, I was starting up a NXT that was connected via USB. Tonite, it happened out of the blue for no explained reason, but the common thing I have noticed is that RobotC was open and running.

Something is happening and I have no idea what it is. Can RobotC mess up the USB ports??


Fri Mar 21, 2008 11:55 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.