View unanswered posts | View active topics It is currently Mon Jun 18, 2018 7:20 pm

Reply to topic  [ 4 posts ] 
How to download firmware to PIC? 
Author Message

Joined: Sat Oct 22, 2011 1:08 pm
Posts: 5
Post How to download firmware to PIC?
Where are the PIC instructions for RobotC 3?

I've seen directions for the Cortex, of course, and directions for some old 1.x and 2.x version of RobotC, but neither seems to apply. I have a very recent version of RobotC.

When I pull down the VIEW menu and choose PREFERENCES I do not see "platform type" or "VEX COMMUNICATION PORT". (as suggested in the old "Download Firmware" PDF.

Trying to use the "Master Firmware Download instructions" (for RobotC for IFI 2.0), I'm stuck. There ae no "download firmware" choices on the "Robot" menu. "Platform type" I can set to V0.5 PIC, but I don't know where the port selection has been moved.

Why is nothing ever easy?

Wed Dec 07, 2011 8:33 pm
User avatar

Joined: Tue Sep 14, 2010 9:19 pm
Posts: 496
Post Re: How to download firmware to PIC?
Have you tried switching your menu level to "superuser"? The platform type is also under the "robot" menu. The port selection should be under View -> preferences -> detailed preferences.

sudo rm -rf /

Wed Dec 07, 2011 9:10 pm

Joined: Sat Oct 22, 2011 1:08 pm
Posts: 5
Post Re: How to download firmware to PIC?
I had put it into superuser for a while but didn't see the detailed preferences. Thanks

There's some kind of communication problem. I'm not seeing a "download firmware" selection yet. In the spot where the "download firmware" should be instead it says i can "Test Communications Link". Of course, that test fails.
Robot controller failed to respond
possibly not powered on
low battery
bad cable
incorrect port selected on PC

I'm thinking it's that last one.

On the view>preferences>detailed preferences>platform tab I can see that the USB is recognized, I can select it (COM4) and "apply" the change, but when I leave the page it changes back to "automatic".

I've tried two cables and two PICs. Only one battery though. It seems charged well enough.

If it helps, the "configure sensors and motors" is grayed out, unlike the menus shown in the directions.

I read about (and tryed) using a transmitter battery to raise the voltage. It didn't help. The software sees the USB cable on COM4 but won't use it.

Thu Dec 08, 2011 2:40 pm
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 409
Post Re: How to download firmware to PIC?
You should be able to find fairly good instructions in the ROBOTC Help. Go to Help > Open Help > Getting Started.

Jesse Flot
CMU Robotics Academy
ROBOTC Support

Tue Dec 13, 2011 11:30 am
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.