View unanswered posts | View active topics It is currently Sat Aug 02, 2014 2:42 am






Reply to topic  [ 5 posts ] 
Unable to get RobotC to connect to Cortex or Controller 
Author Message
Rookie

Joined: Wed Oct 12, 2011 10:56 am
Posts: 6
Post Unable to get RobotC to connect to Cortex or Controller
Here is my RobotC settings & what I see.
Download method is Using VEXnet or USB
Compile target is Physical Robot
Platform type is VEX 2.0 Cortex

Preferences Detailed shows:
Platform: VEXnet2.0 cortex
Comm Port: Automatic Selection, no other otions avalable.

Window Menu Level is set to Basic.

With the robot connected to the computer via USB.
Robot is off: Robot LED is slow blink red, VEXnet is solid green.
Robot is on: Robot LED is slow blink green, VEXnet is solid green.
With the controller connected to the computer via USB.
Controller is off: VEXnet is solid green.
Controllerot is on: VEXnet is solid green.
All other LEDs are off.

I have been reading the forum for clues the last 2 days. Two days ago I managed to update the firmware on both the Cortex & Controller. I also managed to get the VEXnet to connect. When plugging in the USB cable to the computer, I get the "Failed to Connect" sound. This leads me to believe that the driver for RobotC & VEX is not installed properly or set up correctly.

Can someone provide me with some insight?
PS I'm runnig windows 7-64 bit on a HP Pavilion DV6.


Fri Oct 14, 2011 8:35 am
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 403
Post Re: Unable to get RobotC to connect to Cortex or Controller
Did you download and install the drivers for the VEX Cortex? They're not included in the ROBOTC installation. You fan find them here, under "Download the VEX Cortex Device Driver": http://www.robotc.net/download/cortex/

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Fri Oct 14, 2011 9:00 am
Profile
Rookie

Joined: Wed Oct 12, 2011 10:56 am
Posts: 6
Post Re: Unable to get RobotC to connect to Cortex or Controller
Thank you for the responce. I've just re-downloaded the drivers & instructions. I had a brain laps, had the drivers downloaded 2 months ago. When I first investigated what was needed for the IFI Controllers.


Fri Oct 14, 2011 10:46 am
Profile
Rookie

Joined: Wed Oct 12, 2011 10:56 am
Posts: 6
Post Re: Unable to get RobotC to connect to Cortex or Controller
After re-charging the batteries, I lost the connection between the Cortex & Controller. I then re-downloaded the firmwares (Master, Cortex & Controller). I then tried to download the motorPort3Forward.c program to the Cortex via the Programming Cable. I could not get the robot to move with the 269 Motors. I noticed the the Robot Build showed the 3-Wire Motors in stalled. Sow I installed the Motor Controllers (29) & had success. Now I'm following the CMU training with no problems.
Again thanks for the assists.
Having read some of the other posts, I now have ideas for the fish I plan on building.


Mon Oct 17, 2011 8:36 am
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 403
Post Re: Unable to get RobotC to connect to Cortex or Controller
Glad to hear you have everything up and running. Just so you know, the 269 motors can be plugged in directly on ports 1 and 10.

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Mon Oct 17, 2011 8:57 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.