View unanswered posts | View active topics It is currently Tue Feb 19, 2019 10:05 pm






Reply to topic  [ 3 posts ] 
Mower challenge 
Author Message
Rookie

Joined: Sat Jun 21, 2014 12:30 pm
Posts: 8
Post Mower challenge
Had the program for the Mower Challenge completed and nearly to the end of running it the program froze. Had to close the program and open it again and now it appears the setMotor command is not working.

forward(7.3,rotations,50);
resetGyro(port4);
setMotor(motor 1,35);
setMotor(motor 6,-35);
waitUntil(getGyroDegrees(gyroSensorNL)>-88);

when this executes the IQ moves forward is picked up, then the motors stop. The setMotor commands are not executed. I tried the moveMotor command and that works.

thanks for your assistance.


Sun Jul 13, 2014 8:27 pm
Profile
Rookie

Joined: Thu Jun 19, 2014 9:25 pm
Posts: 34
Post Re: Mower challenge
I believe you need to change the > sign to a < sign. The negative numbers from -1 to -87 are larger then -88. They are closer to zero. The joy of negative numbers.

_________________
www.disneymaingatecondo.com
@Oakwater2739


Sun Jul 13, 2014 9:52 pm
Profile
Moderator
Moderator

Joined: Mon Oct 04, 2010 2:18 pm
Posts: 196
Post Re: Mower challenge
Correct. The boolean operators might not have saved when the program froze.


Sun Jul 13, 2014 10:37 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.