View unanswered posts | View active topics It is currently Sat Feb 16, 2019 3:44 am






Reply to topic  [ 1 post ] 
Gyro Sensor on EV3 
Author Message
Rookie

Joined: Thu Sep 11, 2014 12:58 pm
Posts: 1
Post Gyro Sensor on EV3
Brick: Lego Mindstorm EV3
RobotC version: 4.26
Firmware: 10.26 Augst 29, 2014
PC: Windows 8

Using the sample program Basic_Gyro_Turning.c I compiled it and activated windows debugger for Sensors, expecting to see as it rotated clockwise, displaying the degrees, but it displayed negative numbers.
Then I added:

task main()
{
// The code below will rotate the robot 360 degrees and wait 1 second and repeat

resetGyro(Gyro);
setSensorMode(Gyro,0);//angle


The Robot could not be stopped manually or through the PC, I had to open the battery case to reset it. The PC displayed "Failure ' Reading brick status more' (image attached)

I been trying to make it work but no luck, any input on what's wrong?
Thanks


Attachments:
Gyro turning error.JPG
Gyro turning error.JPG [ 118.22 KiB | Viewed 4206 times ]
Thu Sep 11, 2014 1:35 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.