View unanswered posts | View active topics It is currently Tue Aug 04, 2020 2:35 am

Reply to topic  [ 2 posts ] 
ROBOTC debugger window crashes the entire program 
Author Message

Joined: Mon Sep 21, 2015 1:06 am
Posts: 2
Post ROBOTC debugger window crashes the entire program

Version: 4.32 (F/W: 10:32)
Build date: Jun 16 2015
Platform: VEX IQ, text mode.
OS: Windows 7

I was testing out a self-parking program and downloading to the robot quite a bit to test new things, when suddenly, for no apparent reason, the next time I tried to download code to the robot, the program downloaded the code, opened the debugger, and promptly crashed. Now, it does this every time.

I tried closing and opening ROBOTC
I tried running another program -- one of the sample programs.
I tried restarting my computer.
I tried uninstalling and reinstalling ROBOTC in a new location.
Nothing works.

I googled around for answers and saw that someone was saying the debugger itself can cause the program to crash. I disabled it in preferences, and sure enough, I was then able to download code to the robot.

If I go in to the menus, to Robot > Open Debugger Manually, the debugger window appears, and the program immediately crashes.

Is it possible for me to fix this problem?
Alternatively, is it possible to do a COMPLETE un-installation, so that there is not a trace of ROBOTC anywhere on my system, (including the registry) so I can try a fresh install?

I noticed that my menus and other preferences were still the same on the new install - very annoying, since there's some options for menus that cannot be undone. (The text functions auto-hide cannot be tuned off when the program is in debugging mode, for example. But that's another issue.)

robotC crashing from debugger.png
robotC crashing from debugger.png [ 403.84 KiB | Viewed 11538 times ]
Mon Sep 21, 2015 1:27 am

Joined: Mon Sep 21, 2015 1:06 am
Posts: 2
Post Re: ROBOTC debugger window crashes the entire program

Like I suspected, it was something in the registry.

I uninstalled ROBOTC a second time, manually deleted any remaining folders, and deleted the registry files, following these instructions:


Now the debugger works, the program doesn't crash, AND the other windows are back to normal.

I still don't know what caused the error, and I hope I don't have to do such a drastic fix for problems in the future.

The only thing I can think of was my use of sleep(00); but I'm not gonna risk trying that again to verify.

Note: my menu level was set to "super user," if that makes any difference.

Another note, not related: The auto saving features will automatically overwrite the sample programs. This is bad news, since I use them as a basis for tinkering around, deleting and adding code haphazardly and experimentally, destroying the original code. I didn't expect any of that to be SAVED, since I never told it to save, AND I assumed the sample programs wouldn't be over-writable anyway.

Fortunately, I got back the default sample programs when I reinstalled ROBOTC. But those should definitely NOT over-writable.

Mon Sep 21, 2015 1:52 am
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.