ROBOTC.net forums
http://www.robotc.net/forums/

Gratuitous motor motion - EV3 RobotC 4.30
http://www.robotc.net/forums/viewtopic.php?f=63&t=10562
Page 1 of 1

Author:  CARBOT [ Sat Feb 21, 2015 10:51 am ]
Post subject:  Gratuitous motor motion - EV3 RobotC 4.30

Before the task main commences to execute, there is about 1/10 revolution of the motor connected to port D, but only on successive runs. The first run after power up is OK. I removed as much code as I could where it would still occur so my code is ruled out.

I am using RobotC 4.30 (FW10.30) with an EV3.
My PC runs Windows 7.I have swapped motors to confirm it is not the motor.

I believe this did also happen on 4.28 and 4.29 versions of RobotC.
It occurs independent of the program completing itself or being manually terminated.
It occurs when tethered to a PC or running it from the EV3.
I suggest it is before task main starting because if you add anything to the code the movement occurs prior to the added code. Such as moving another motor.
It seems to happen independent of the motor label, independent of the PID setting, and independent of the right/left/none setting.

Code:
#pragma config(Motor,  motorA,          one,           tmotorEV3_Large, openLoop)
#pragma config(Motor,  motorB,          two,           tmotorEV3_Large, openLoop)
#pragma config(Motor,  motorC,          three,         tmotorEV3_Large, openLoop)
#pragma config(Motor,  motorD,          four,          tmotorEV3_Large, PIDControl, encoder)
//*!!Code automatically generated by 'ROBOTC' configuration wizard               !!*//

task main()
{


}


Could someone else put a motor in port D and tell me if they see this as well?

Author:  Sigtrygg [ Sat Feb 21, 2015 3:17 pm ]
Post subject:  Re: Gratuitous motor motion - EV3 RobotC 4.30

Hello Carbot!

I tried your code with the same settings. I use EV3 with four motors (NXT), RobotC 4.30, FW 10.30 and Win 7, too.
I can't repoduce the behavior of Motor D. I started, stopped, started and so on, but nothing happened. The encoders stayed at zero.

Regards,

Sigtrygg

Author:  CARBOT [ Sun Feb 22, 2015 12:38 am ]
Post subject:  Re: Gratuitous motor motion - EV3 RobotC 4.30

Thanks Sigtrygg. I wanted to run it with the EV3 software to see if it happened there. I updated my EV3 software, upgraded my EV3 firmware and it worked OK. I then reloaded the RobotC kernel, reloaded the RobotC firmware and ran without issues. I have an early production EV3 that has gotten a lot of shelf time so maybe something just needed to work itself out.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/