ROBOTC.net forums
http://www.robotc.net/forums/

SlaveCPU?
http://www.robotc.net/forums/viewtopic.php?f=63&t=10070
Page 1 of 1

Author:  bforney [ Mon Dec 22, 2014 5:13 pm ]
Post subject:  SlaveCPU?

One of my students is getting the following error message when compiling and downloading his program:

"Failed to verify that the serial link is connected to a Robot Controller.

Cannot communicate with VEX Cortex SlaveCPU. Master CPU communication is working."

I don't know what the slave CPU is. We have tried a different cable and have tried re-updating firmware.

We work with RobotC 4.0, Vex Cortex 2.0 (?), and are running Windows 98 OS on a Mac using Bootcamp.

Any insight would be greatly appreciated -- Brian

Author:  Pdcook [ Fri Feb 06, 2015 7:14 pm ]
Post subject:  Re: SlaveCPU?

I hope you figured your issue out. I was looking for a fix to the same problem. I finally figured it out after a few choice words and pulling out a few hairs though, so for anyone else experiencing the same problem, the issue is that there is something the bootloader just doesn't give the microcortex. Still use the bootloader to update the microcortex, but you also have to hook up to robotc and do a firmware download also. Soon as that's done it will communicate again.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/