ROBOTC.net forums
http://www.robotc.net/forums/

License issues
http://www.robotc.net/forums/viewtopic.php?f=53&t=2588
Page 1 of 1

Author:  lasarobotics [ Sat Sep 18, 2010 12:31 pm ]
Post subject:  License issues

We tried to install our copy of RobotC from the CD we were given for the BEST competition, but once we finally got through the download and tried to open the program, we got the message "Error occurred #7 -> CANNOT OPEN FILE". If we try to open it by just clicking on one of the sample programs in Windows Explorer, it gives us "Error occurred #15 - Missing License File: Make sure you have downloaded your license file and that the license file is in the same directory as the ROBOTC application". The license was accepted during the install so we have the license file, and it's in the correct location, but the program doesn't seem to recognize that it's there. Any assistance would be appreciated. Thanks for your time.

Attachments:
File comment: screen shot of the error # 7 message and the license file in the correct folder
Error 7.PNG
Error 7.PNG [ 84.6 KiB | Viewed 12383 times ]

Author:  chrisb [ Sat Sep 18, 2010 6:52 pm ]
Post subject:  Re: License issues

I have had the same problem. I am using Windows 7 Professional and my acccount has administrative privileges. The installation seems to work (i.e., it does not say anything was wrong), but when I try to run program, it says "Error occurred #7 -> CANNOT OPEN FILE" and exits.

Author:  chrisb [ Sat Sep 18, 2010 7:53 pm ]
Post subject:  Re: License issues

I found a solution. I opened the program folder in Windows Explorer (C:\Program Files (x86)\Robotics Academy\ROBOTC for IFI). At this point, if I double-clicked the RobotCIFI program to run it, I got the error (Error #7 ...). However, if I right-clicked it and selected Run as Administrator, the program opened properly. Since doing this one time, now I can open it the normal way, without doing the Run as Administrator thing. (I use a Windows 7 Professional laptop PC and my account has full administrative privileges.)

Author:  lasarobotics [ Sat Sep 18, 2010 9:01 pm ]
Post subject:  Re: License issues

Yay! That worked! Thanks so much!!

Author:  vnguyen [ Sat Sep 18, 2010 9:31 pm ]
Post subject:  Re: License issues

This can actually be found in the Cortex and VEX Support pages:

http://www.robotc.net/support/troublesh ... rror42.php

I will make sure to update it to include Windows 7.

Author:  chrisb [ Sun Sep 19, 2010 10:25 pm ]
Post subject:  Re: License issues

Vu - This is not quite the same error. Your link refers to error #42, whereas what the other user and I reported was a problem with error #7. The solution appears to be the same, but a person searching for a fix to error #7 may not read a solution that is listed as being for error #42.

Author:  tfriez [ Mon Sep 20, 2010 11:27 am ]
Post subject:  Re: License issues

This is a known issue with versions of ROBOTC that use License Files (.lf) to dictate expiration dates. The error occurs with Windows 7 and Windows VISTA not being able to initialize the license file without administrator privileges. Once the license file is initialized, ROBOTC works as expected and does not required Administrative rights.

The solution to this error is as follows:
"You may need to run ROBOTC as an Administrator for the first time in order to activate the license. To do this, right click on the ROBOTC for Cortex icon and select "Run as Administrator". Once the software is activated, you will not need to do this again."

If you download the latest BEST version - 2.25 - available at http://www.robotc.net/best/ - this issue will not occur as it does not rely on the license file.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/