ROBOTC.net forums
http://www.robotc.net/forums/

VEXnet pairing works for a time, until program download
http://www.robotc.net/forums/viewtopic.php?f=53&t=2584
Page 1 of 1

Author:  milan95 [ Wed Sep 15, 2010 5:36 pm ]
Post subject:  VEXnet pairing works for a time, until program download

Hi there,

We're having a problem with VEXnet Joystick-Controller pairing. We are able to get the Joystick and the Cortex pairing when there is a fresh firmware download on both the Cortex and the Joystick. When we download a program to the Cortex, the Joystick no longer pairs, doing one of two things:
1. The Cortex flashes only the "GAME" light on green and the Joystick flashes the "VEXnet," "ROBOT," and "JOYSTICK" lights on green
2. The Cortex flashes only the "GAME" light on green and the Joystick flashes only the "ROBOT" light on orange.]

We have tried downloading sample programs, and ones that just run motors work just fine. Ones that use the controller have no luck whatsoever. We also tried our own custom code that we've been working on, that didn't work either. We also tried a direct tether from the Joystick to the Cortex via USB A-A cable, and that didn't work either.

Please help us.

Thanks in advance.

Author:  jbflot [ Wed Sep 15, 2010 9:04 pm ]
Post subject:  Re: VEXnet pairing works for a time, until program download

VEXnet is a pretty sophisticated system. As such, there's a number of factors that can introduce technical issues. A few suggestions / things to check:

1. Are you using the latest version of ROBOTC (2.25)? http://www.vexforum.com/wiki/images/4/42/VEXnet_LED_Patterns.pdf
2. Have you downloaded all 3 firmware files using the latest version (Cortex Master CPU Firmware, Cortex ROBOTC Firmware, Joystick Firmware)?
3. Are your batteries reasonably new/healthy?
4. What does your remote control code look like? Here's a link to a program that we've verified works: http://www.education.rec.ri.cmu.edu/fire/media/best_webinars/week2/Remote_Control.c
5. Are you working in an environment that has lots of wireless traffic, or where the network security actively shuts down wifi networks? This page contains a link for a VEXnet MAC Utility for your IT department, in order to collect and approve the IP addresses: http://www.vexforum.com/wiki/index.php/Software_Downloads
6. Here's a link to the LED Color codes, to help diagnose where the problem is: http://www.vexforum.com/wiki/images/4/42/VEXnet_LED_Patterns.pdf

Author:  milan95 [ Wed Sep 15, 2010 10:43 pm ]
Post subject:  Re: VEXnet pairing works for a time, until program download

After a few hours of fiddling with it, we realized we'd set the download option in ROBOTC to USB only, instead of USB and VEXnet. Set it back and everything worked again. Thanks for all the help, though!

Author:  sphuss [ Thu Aug 25, 2011 12:19 pm ]
Post subject:  Re: VEXnet pairing works for a time, until program download

We have a similar issue (a VEX pairing problem, that is).
We are a team new to VEX and have just begun to work through the RECbot, RobotC training. After successfully downloading firmware (master, robotc, and joystick) we are able to pair joystick and cortex. However, when the VEXnet keys are inserted into joystick and cortex and turned on - all is good for a brief moment - green lights on the VEXnet LED's, but then the VEXnet connection goes red. During the brief (1 second or so) connectivity, we can control the robot with downloaded code, but after - nothing. This phenomenon has been repeated a few times with a few robots.
Any suggestions?

Author:  jbflot [ Wed Sep 14, 2011 9:11 am ]
Post subject:  Re: VEXnet pairing works for a time, until program download

It might be your code. What program are you downloading to the robot?

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/