ROBOTC.net forums
http://www.robotc.net/forums/

program not downloading
http://www.robotc.net/forums/viewtopic.php?f=52&t=865
Page 1 of 1

Author:  evjackso [ Tue Oct 28, 2008 4:03 pm ]
Post subject:  program not downloading

I just downloaded the update to RobotC, and I attempt to download and run a program. When i click start on the debug window, it says "failed to start, try re-downloading." Naturally, I re-downloaded the program and I received another error message:
" Failed to open communication link to NXT brick. Check if brick is powered on and line (USB or BT) is setup
Error code: NXT BATTERY LEVEL (-31.742V) too low to proceed. "

I tried it over usb and received similar results. I made sure that, and i am certain that here is a link between my pc and the the brick. Also the battery is completely charged. Any suggestions or similar issues.

Author:  CC335 [ Tue Oct 28, 2008 8:30 pm ]
Post subject:  Re: program not downloading

That's a faulty NXT if I ever saw one. the battery level shouldn't be that low, otherwise the NXT wouldn't work in the first place! Send the NXT back to LegoEducation to have it replaced.

Wow, -31.742 volts...

Author:  tfriez [ Wed Oct 29, 2008 10:21 am ]
Post subject:  Re: program not downloading

Do you have the latest USB fantom driver installed?

Try resetting the NXT... Push and hold the "magic" reset button found in the bottom of the stud hole by the USB connector. Hold it in for at least 10 to 15 seconds.

What version of ROBOTC are you using?

Author:  evjackso [ Wed Oct 29, 2008 4:00 pm ]
Post subject:  Re: program not downloading

tfriez and cc335, this happened to two nxt's, that previously worked. I am not sure why this is happening now. CC335 I am not sure what you mean by the latest USB fantom driver, and i am using the latest version of RobotC that i downloaded yesterday.

Author:  Dick Swan [ Thu Oct 30, 2008 11:28 pm ]
Post subject:  Re: program not downloading

ROBOTC performs an integrity check on the battery level before writing files to the NXT as at marginal battery level the NXT CPU operates OK except when writing to flash, corruption can occur. The corruption can occur at any flash location and not simply the addresses that you're trying to write.

Clearly what's happening here is that the message to retrieve the battery value from the NXT is returning a garbage result. You won't get a ngeative battery level.

I suspect what's wrong here is that something has got out of sync. This could be: Firmware version mismatches, USB communications is corrupted, or something similar.

One or more of the following is likely to clear the problem:
  • Power cycle the NXT
  • Unjack and rejack the USB connection to the NXT.
  • Exit and re-enter the ROBOTC application.
  • Restart Windows and re-enter the ROBOTC application.
  • Reload the firmware on the NXT. You may have to use the hidden reset button at the bottom of the "stud" hole underneath the USB port. Use a straigtened paper clip to push the button in. The NXT should be powered on first. Hold the button in for at least 10 to 15 seconds. You should be able to hear a very faint clicking from the NXT to indicate it is in boot mode. Then you can always reload firmware
  • Uninstall and re-install ROBOTC
I would try the above in sequential order until one of them works.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/