ROBOTC.net forums
http://www.robotc.net/forums/

CRASH!!!
http://www.robotc.net/forums/viewtopic.php?f=52&t=842
Page 1 of 1

Author:  CC335 [ Wed Oct 22, 2008 10:23 am ]
Post subject:  CRASH!!!

RobotC crashed while I was running a small test/scout robot based on the design of the Spybotics Technojaw T55. The NXT froze, and robotC stoped responding to my input. I don't know why it did that.

Author:  tfriez [ Wed Oct 22, 2008 1:38 pm ]
Post subject:  Re: CRASH!!!

Can you post your source code?

We need more information than "it just crashed" to help. Did your NXT power off, did the battery get too low? Did your BT adapter abruptly get disconnected?

Author:  CC335 [ Wed Oct 22, 2008 8:48 pm ]
Post subject:  Re: CRASH!!!

The problem is that I don't have any info besides the source code and what happened in detail, and the source code probably won't help knowing that it's just standard stuff.
What happened was that while I was driving the robot, the controls stuck in the debug window, and the robot started running off. When I looked at the NXT screen, it had froze. It hasn't done that since.

Author:  tfriez [ Wed Oct 22, 2008 9:57 pm ]
Post subject:  Re: CRASH!!!

If I were to guess, I would say that it was the FANTOM driver (LEGO/NI's communication driver for NXT communication) went into a "time-out" mode because the BT link got lost to the NXT.

Basically... the NXT dropped the BT somehow, Fantom was in the middle of connecting... then locked up because it couldn't find the NXT anymore... and then ROBOTC "froze"... ROBOTC would have come back alive after about 30 seconds, once Fantom finally timed out fully and returned to ROBOTC that it had.

If it keeps happening, we can investigate it a little more using the message log... but I think may just be the joys of using BT and having it disconnect.

On a side note, I hear Newegg is having a sale on USB extension cables... :D

Author:  CC335 [ Thu Oct 23, 2008 3:03 pm ]
Post subject:  Re: CRASH!!!

USB has it's own problems, like the tether/cable that is required for the link.
btw I got a serial port PCMCIA card from Newegg for 2 lego spybots that we have ordered for X-mass off of ebay. G60 and S70.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/