View unanswered posts | View active topics It is currently Mon Jun 18, 2018 11:06 pm

Reply to topic  [ 4 posts ] 
nxt firmware not reading 
Author Message

Joined: Fri Feb 26, 2010 12:46 am
Posts: 1
Post nxt firmware not reading
help! I am trying to have the firmware read by the nxt and its not loading it or find the brick. I have tried everything dont know what else to do.Help! It keeps telling NO NXT Bricks connected.

Fri Feb 26, 2010 12:55 am

Joined: Tue Mar 18, 2008 7:11 pm
Posts: 22
Location: San Antonio, TX
Post Re: nxt firmware not reading
I'm experiencing the same problem.

RobotC 2.01
Windows Vista and Windows 7

BT Connections are working, but USB Connection doesn't seem to be working anymore.

The Device Manager is showing the brick as a Lego Mind Storms NXT and the Boot Mode when the NXT is manually put in boot mode. Disconnect it from the USB and the device disappears.

Not sure if this is a Vista/Windows 7 issue or not. It had worked in the past however.


Sun Mar 14, 2010 8:13 pm
Site Admin
Site Admin
User avatar

Joined: Wed Mar 05, 2008 8:14 am
Posts: 3654
Location: Rotterdam, The Netherlands
Post Re: nxt firmware not reading
It's not a Vista/Windows 7 thing. I've used Vista in the past (32 + 64 bit) and am using Windows 7 64 bit now. You did install the correct drivers? Ie 32 bit driver for a 32 bit system and the 64 bit drivers for a 64 bit system.

Are you running NXT-G at the same time? That wouldn't work as it tries to poll the brick constantly.

Download the drivers again and try uninstalling the driver and reinstalling from there. You can download them from this page: [LINK].

- Xander

| Professional Conduit of Reasonableness
| (Title bestowed upon on the 8th day of November, 2013)
| My Blog: I'd Rather Be Building Robots
| ROBOTC 3rd Party Driver Suite: [Project Page]

Mon Mar 15, 2010 2:54 am
Profile WWW

Joined: Tue Mar 18, 2008 7:11 pm
Posts: 22
Location: San Antonio, TX
Post Re: nxt firmware not reading
Well, it is working now. I set the compatibility mode to Windows XP SP3 and Run as Admin and it worked, but I don't think that really had anything to do with it. I undid those settings and it is still working.

Mysterious.... :)

Also, I never run two apps that access the NXT at the same time.


Tue Mar 16, 2010 7:39 pm
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.