View unanswered posts | View active topics It is currently Thu May 24, 2018 6:18 am

Reply to topic  [ 4 posts ] 
RobotC 2.0 and Firmware Issues 
Author Message

Joined: Thu Nov 19, 2009 8:35 pm
Posts: 1
Post RobotC 2.0 and Firmware Issues
Our NXT brick doesn't execute any programs since we upgraded to RobotC 2 and redownloaded the firmware.
Here's some more details:
1) Right after upgrading, I successfully downloaded some example encoder code to the NXT brick. These ran pefectly fine. (Although the code involving the encoder didn't work as we wanted it to)
2) As a last ditch effort to fix the encoder problem, I upgraded the NXT firmware to whatever version is included with RobotC 2.0 (Was the firmware different than the one included in RobotC 1.93?)
3) After upgrading the firmware, we can get a Bluetooth connection and download a program to the NXT, but once downloaded, pressing the run button does nothing!
4) I also installed NXT-G and downloaded NXT-G firmware to the NXT. I was able to download and run an NXT-G program without any problems
5) Once I switched back to RobotC and redownloaded the firmware, I had the same problem as before

Any suggestions?

And the problem that led us down this path - encoders. Has anyone had success with the sample code? We tried using both nMotorEncoder[] and nMotorEncoderTarget[].


Thu Nov 19, 2009 8:36 pm

Joined: Tue Nov 03, 2009 5:28 pm
Posts: 5
Post Re: ROBOTC 2.0 and Firmware Issues
I'm having the same problem! I've tested it with all sorts of programs, and nothing will run. None of the programs I ran included encoders, and they still wouldn't run. If anyone can fix this problem or knows why it does this, please tell me!

For now, it's advisable to just downgrade to a lower version.

Fri Nov 20, 2009 4:45 pm

Joined: Sun Nov 22, 2009 9:25 pm
Posts: 1
Post Re: ROBOTC 2.0 and Firmware Issues
I am having the same problems with the firmware. We have tried it on two different bricks and neither work with the new firmware installed.

Unfortunately I don't have any older versions of the firmware to download is there anyway to obtain them.

Sun Nov 22, 2009 9:28 pm

Joined: Fri Feb 09, 2007 9:21 am
Posts: 616
Post Re: ROBOTC 2.0 and Firmware Issues
This problem may be a symptom of the attached problem that has been documented elsewhere on the blogl.

This is a case of the ROBOTC compiler trying to be "too smart" and generating a bug. The compiler tries to economize on when it actually has to compile programs and when it can use the results of the last compile. With release 2.0, ROBOTC now has the capability to have multiple windows of source code files open. As well, prior to release 2.0, ROBOTC always saved intermediate changes to disk as part of a compile; it no longer does this with release 2.0. Unfortunately this broke the "smart" decision on when a compile is necessary.

The fix is in hand and should be released this week.

Meanwhile the workaround that works in almost all cases is to do both a "Compile" (F5) and "Compile and Download" (F7) rather than a single "Compile and Download" (F7). If this doesn't work, then also try a manual save before the compile. These are only workarounds prior to the proper bug fix release.

Tue Dec 01, 2009 3:31 am
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.