ROBOTC.net forums
http://www.robotc.net/forums/

NXTCam V4 connecting to AVR Studio problems
http://www.robotc.net/forums/viewtopic.php?f=41&t=4362
Page 1 of 1

Author:  matcuha123 [ Fri Mar 16, 2012 3:53 am ]
Post subject:  NXTCam V4 connecting to AVR Studio problems

I can't connect NXTCam v4 to AVR Studio 4 (recommended version in User Guide)
I'm thinking I'm doing everything according to User Guide.

This is way I'm doing it:
1.Connect NXTCam v4 to PC via USB
2.Connect NXTCam v4 to NXT Port 1, then I turn on NXT (In NXT I use 1.28, this is recommended)
3.Run program avr-boot.
4.Select Boot option. LED on camera blinks about 3 times
5.Opening AVR Studio 4
6.Selecting tab 'Connect'(Tools > Program AVR > Connect)
7.In connect window I select ST500, port COM2 (I know this port from NXTCam setup in Windows 7 64-bit)
8.I press connect and I get 'Connect Failed' window

Thank you for answers.

P.S NXTCam version: V3.2D

Author:  mightor [ Fri Mar 16, 2012 4:38 am ]
Post subject:  Re: NXTCam V4 connecting to AVR Studio problems

matcuha123,

Did you try contacting the Mindsensors support? You can contact them at support@mindsensors.com. I don't have a V4, but I do have a V3 and to be honest, it's been a while since I programmed my camera so I don't really remember how I did it.

Btw, you can also use my little ROBOTC program to boot the camera and reset it. It's available from the Mindsensors website but I've attached it to this post. I just tested it in ROBOTC 3.08 and it works fine :)

- Xander

Attachments:
avr-boot.c [1.44 KiB]
Downloaded 714 times

Author:  mollete [ Thu Dec 06, 2012 6:21 pm ]
Post subject:  Re: NXTCam V4 connecting to AVR Studio problems

Did it work?

I have the same problem, everything seem to be ok but it doesn't connect to AVR...

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/