ROBOTC.net forums
http://www.robotc.net/forums/

Has EV3 I2C for 3rd party sensors been fixed?
http://www.robotc.net/forums/viewtopic.php?f=41&t=10007
Page 2 of 2

Author:  OliviliK [ Wed Feb 04, 2015 5:22 pm ]
Post subject:  Re: Has EV3 I2C for 3rd party sensors been fixed?

Xander,

The HT Compass test works properly with my EV3 (4.28 beta). I did notice that this example was done without using a pragma to define the sensor port assignment.

What is the future recommended practice? Will pragmas be replaced by

Code:
#include "<driver>.h"
:
  <sensor type> <sensor name>
:
  initSensor(&<sensor name>, S<port number>);


How this will work with the sensor multiplexer?

Cheers, Ollie

Author:  mightor [ Thu Feb 05, 2015 1:46 am ]
Post subject:  Re: Has EV3 I2C for 3rd party sensors been fixed?

The pragmas are not mandatory, but they can help.

As for the SMUX, it is supported for some sensors, just check out the examples that have the word SMUX in them :)

The upcoming release of ROBOTC has some additional fixes for I2C. I2C sensors that require the 9V pin to be active require a bit more tweaking in their drivers until I have implemented a more permanent fix in the firmware and IDE.

= Xander

Author:  mightor [ Fri Apr 10, 2015 6:14 am ]
Post subject:  Re: Has EV3 I2C for 3rd party sensors been fixed?

You should be using the driver suite from the Github repo: https://github.com/botbench/robotcdriversuite :)

= Xander

Author:  mightor [ Mon Apr 13, 2015 8:40 am ]
Post subject:  Re: Has EV3 I2C for 3rd party sensors been fixed?

Did you look at the examples and how the pragmas are configured? You cannot use sensorHiTechnicIRSeeker1200 and the driver suite at the same time. You will also notice that you cannot use SensorValue(). So, make sure you read the examples very thoroughly.

= Xander

Author:  millahjovich [ Mon Jun 13, 2016 6:41 am ]
Post subject:  Re: Has EV3 I2C for 3rd party sensors been fixed?

I tried HT compass sensor and sonar sensor with LEGO Software and it works.
I made a mistake because I never used this Software.
Sorry for confusion!

Page 2 of 2 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/