ROBOTC.net forums
http://www.robotc.net/forums/

HELP
http://www.robotc.net/forums/viewtopic.php?f=21&t=507
Page 1 of 1

Author:  definacho [ Fri Apr 04, 2008 5:37 pm ]
Post subject:  HELP

i need help with the vex microcontroller. i am using robotc for my programing. i loaded a program, just to test it (i am a novice) and it seems as if i cant load any other programs. it seems as if it is running the same program as the previous. it wont stop moving, according to our program, it is supposed to stop moving. i dont know what to do. is there a reset? or is my programming way off? i am using sample programs to test it so you think that they should help.

Author:  vnguyen [ Sat Apr 05, 2008 10:11 am ]
Post subject: 

First, I want you to download the robotc firmware onto the VEX by going to the ROBOT menu > Download Firmware.

Then, power cycle your VEX - turn the power switch to the OFF position, then to the ON position.

Next, try typing in a simple program like this:

Code:
task main()
{
     bMotorReflected[port2] = 1; // This is used if you want to flip a motor's direction

     motor[port3] = 127;
     motor[port2] = 127;
     wait1Msec(2000);
}


Note: in order for this code to work, your left motor should be plugged into Motor port 3, and your right motor should be on Motor port 2.

Make sure your robot is in the ON position, and then Compile and Download this program by going to the ROBOTC menu > Compile and Download (or just Download program if you've already compiled).

You can then RUN this program by clicking on the START button on the Program Debugger window that pops up. Or... you can run the program by switching your robot OFF, then ON. When your robot starts up, it will automatically run the program.



Also, please post your code so that I can see what's wrong with it.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/