ROBOTC.net forums
http://www.robotc.net/forums/

Communications
http://www.robotc.net/forums/viewtopic.php?f=11&t=6816
Page 1 of 1

Author:  jutterbea [ Thu Sep 12, 2013 2:01 pm ]
Post subject:  Communications

I have never had this happen before. Just moved into a new school district and bought all brand new vex kits and installed RobotC. After instillation, downloading firmware, and the rest of the standard items, when i compile and download a program an error comes up that says no communication link available with VEX device check that your device is connected to PC. Everything is connected and functional so I am lost. Any help please???

Author:  Bluerope2013 [ Sat Dec 07, 2013 4:09 pm ]
Post subject:  Re: Communications

I have run into this problem before when I was working with Robot C. There are multiple things that you can do to fix it. These are the ones that I find to work:
Close Robot C and then reopen it, than compile and download again.
Reboot your computer.
Download the firmware again.

What I have noticed is that if you copy and paste programs too much you will corrupt the entire program. So what I recommend is that you download the firmware again every few times that you are one. Hope this helps and that it works. If you have anymore questions or problems please message me them and I will do my best to figure them out. Thank you and have a nice day.

-Bluerope2013

Author:  petriemep [ Mon Jan 13, 2014 7:06 pm ]
Post subject:  Re: Communications

My Cortex was working fine for the last 2 weeks, including earlier today. I then tried to use it again tonight and I am getting the same error message "no communication link available with VEX device check that your device is connected to PC." I tired what you recommended and nothing works. I then connected a different cortex to my computer and it worked fine. I just purchased these VEX Cortex this past summer. Is it possible that I have a defective one?

Author:  Kevin Selavko [ Tue Feb 04, 2014 12:22 am ]
Post subject:  Re: Communications

Late reply, but are using vex net or a direct connection?

Author:  Savant [ Thu Feb 13, 2014 12:29 pm ]
Post subject:  Re: Communications

It sounds like the driver needs to be installed for the communicaiton port you are using. Try this: With Robot C open, go to Robot>Select Cortex Communication Mode>USB Only. Then, unplug the USB from the computer and close out Robot C. Plug USB into a different USB port on the computer. Generally, you will see the driver install, but this is not always the case. Go ahead and reopen RobotC. Check that there is a communication link by clicking View>Select Communication Port. You should see Automatic selected (which is correct) and an additional COM Port showing is it setup for a VEX device. Keep Automatic selected. Go ahead and download the firmware using the automatic method. Hope this helps.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/