ROBOTC.net forums
http://www.robotc.net/forums/

Updating firmware
http://www.robotc.net/forums/viewtopic.php?f=11&t=5706
Page 1 of 1

Author:  redruf [ Mon Apr 15, 2013 1:01 pm ]
Post subject:  Updating firmware

RobotC 3.6
Cortex controller

Having all kinds of issues updating the firmware on the Vex Joystick.
If I try putting it into CONFIG mode holding down the button I get a USB error not recognized.

If I don't use the CONFIG button
after a second I hear the USB bong..then
Every time I try to update it gets to EXACTLY 73% and says:
Failed to enter "Master CPU" downloading mode. Check the following:
then it gives me the list.

Furthermore...it looks like it is stuck in CONFIG mode because the robot led flashes green slowly and the game led flashes fast.
If I unplug everything and turn off the joystick...it goes right back into what I think is CONFIG mode with the robot and game led flashing...but at different rates.

Man I'm usually pretty good at this stuff but I'm pulling my hair out!

Author:  redruf [ Mon Apr 15, 2013 3:51 pm ]
Post subject:  Re: Updating firmware

OK, got that handled..
Now it wont do the joystick..

It keeps telling me I have to have a USB A to A cable hooked up...which I clearly do.

I tried putting it into Update mode with the CONFIG button and then I get a USB error saying not recognized.
Really stumped...tried everything.
:crying:

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/