Program not downloading to PIC
Page 1 of 1

Author:  Linkcat [ Mon Apr 08, 2013 4:38 pm ]
Post subject:  Program not downloading to PIC

When I try to download a program to the PIC controller I get the error

Robot controller failed to respond.
Possibly not powered on or corrupted firmware.
Or low battery condition.
Or cable connections between controller and PC are wrong.
Or incorrect port is selected on PC.

I have followed the steps in the Getting Started guide exactly. I have searched for solutions to the error and I haven't found anything that worked. I saw that SmartBoard software can cause problems with Cortex, but I don't know about PIC. I'd like to know for sure because it would be a hassle to fix. Can anyone help me?

Author:  Eddie [ Mon Apr 08, 2013 5:09 pm ]
Post subject:  Re: Program not downloading to PIC

Just to check over the easy stuff:

    You have a fully charged battery plugged into the PIC
    You are using the orange cable provided for the PIC. It should be half phone cable/half USB cord and have a small box in the center
    You have installed the newest driver available and can confirm that the PIC is listed as COM# in the Device Manager
    You have downloaded all of the appropriate firmwares to the PIC (Master Firmware -> RobotC firmware)
    You have the platform configured as Innovation First (IFI)->VEX 0.5 PIC in the RobotC Robot->Platform Type Menu
    You have the Compiler Target set as Physical Robot

Author:  JohnWatson [ Mon Apr 08, 2013 10:27 pm ]
Post subject:  Re: Program not downloading to PIC

I agree with what Eddie has said; please double check all of those things to make sure they are not the culprit. Also, I would suggest using the 'IFI Loader 4 PIC' to attempt a download of the default PIC firmware. This will help narrow down if it is a ROBOTC specific issue or a different issue with the PIC/computer that is trying to download the firmware.

There are a couple more questions that can help us with the debugging as well:

Does this happen with only one PIC, or does it happen with multiple PICs?
Does this happen on one computer, or does it happen on multiple computers?
Does this happen with one specific USB cable, or does it happen with multiple cables?
Which version of ROBOTC is being used? (This can be checked by navigating to the 'Help -> About ROBOTC' menu option and noting the version number in the bottom left corner)

Thank you in advance for the information, the better the details you can give us the better we will be able to assist you.

Author:  Linkcat [ Tue Apr 09, 2013 4:58 pm ]
Post subject:  Re: Program not downloading to PIC

Eddie, I have already triple checked those. I meant it when I said I followed the steps exactly.

John, We have tried it on two PIC's and we can only get access to one cable and one computer. We have tried 3.54 for Cortex and PIC and 2.02 for PIC.

Thank you both for your quick responses!

Author:  Linkcat [ Tue Apr 16, 2013 4:50 pm ]
Post subject:  Re: Program not downloading to PIC


Author:  Kevin Selavko [ Wed Apr 17, 2013 7:35 pm ]
Post subject:  Re: Program not downloading to PIC

Are you just starting out or did this randomly happen?

Author:  vnguyen [ Thu Apr 18, 2013 2:42 pm ]
Post subject:  Re: Program not downloading to PIC

Have you tried if 3.60 solves the issue?

If not, it sounds like it might be a bad cable. Anyway, report back and let us know.

Author:  Rusty2010 [ Tue May 14, 2013 11:52 am ]
Post subject:  Re: Program not downloading to PIC

There is a line of code that you need to put in the program. I used to use the PIC controller but it has been awhile and I don't remember the exact command. I will look around for my old programs and see if I can find an example.

The line I was thinking of is

bIfiAutonomousMode= true;

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group