ROBOTC.net forums
http://www.robotc.net/forums/

Robotc 3.54 losing Robot configuration
http://www.robotc.net/forums/viewtopic.php?f=11&t=5268
Page 1 of 1

Author:  gokul [ Sun Dec 16, 2012 4:28 pm ]
Post subject:  Robotc 3.54 losing Robot configuration

I upgraded (thanks to the message pop up) from 3.08 to 3.54. Now I get a "Encountered an Improper Argument" window every time I open the Motors and Sensors setup and everytime I click on the Motors tab. This happens with the Sample programs also.
Further the config screen does not show all the motors - just one. The sensors seem to show up correctly. Program compiles without errors.
More worrisome - even the changed Motors setup does not seem to be saved back.

I tried going back to 3.08 but I get a message about newer version should be uninstalled. I am not sure if it is safe to do this because I am not sure how my license would be treated.

Any help?
thanks

Author:  JohnWatson [ Wed Jan 30, 2013 10:44 am ]
Post subject:  Re: Robotc 3.54 losing Robot configuration

For reference; this particular issue was resolved by uninstalling and reinstalling ROBOTC. It was an isolated issue specific to one computer and is not considered a known error with ROBOTC.

Edit: Confirmed bug in ROBOTC 3.54 specific to the PIC platform type; [urlhttp://www.robotc.net/forums/viewtopic.php?f=1&t=5551]fixed in 3.59 BETA[/url] (see below for more information).

Author:  vaughatg [ Thu Feb 07, 2013 9:43 pm ]
Post subject:  Re: Robotc 3.54 losing Robot configuration

John,

I am having exactly the same problem with the 'encountered an improper argument' on 3 computers. I unloaded and reloaded the software but still the same error.
Any other ideas?
Thanks

Author:  JohnWatson [ Fri Mar 15, 2013 6:49 pm ]
Post subject:  Re: Robotc 3.54 losing Robot configuration

I have edited my previous post to reflect this, but:

We debugged this issue further and did find this to be an issue with ROBOTC that specifically appeared when trying to change the setup of Motors in the Motors and Sensors Setup window (with PIC as the platform type). Quoted from our 3.59 BETA log:

Quote:
Enable emulator for VEX PIC. Fix subsequent bug with “Motors” debugger display for VEX PIC locking up IDE when emulator is enabled; this bug should be limited to VEX PIC Emulator only.


To solve this issue, take a look at the ROBOTC 3.59 BETA that has the fix implemented. I apologize for any inconveniences this may have caused.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/