View unanswered posts | View active topics It is currently Fri Aug 01, 2014 9:18 am






Reply to topic  [ 3 posts ] 
Driver/Connectivity Issue? 
Author Message
Rookie

Joined: Wed May 02, 2012 6:59 am
Posts: 2
Post Driver/Connectivity Issue?
I'm the tech for a school district using RobotC 2.32 with a Cortex Microcontroller Rev A3.

We are having issues getting RobotC to see the microcontroller. The directions say that the RobotC should have the drivers included but after installing RobotC onm Windows XP and plugging the microcontroller in, it does not find the correct drivers.

After installing the "CORTEX & VEXnet Joystick Drivers (for XP and Windows 7)" from http://www.robotc.net/download/cortex/ the device is detected as "Vex Robotics Comm Port (COM3 or COM4 depending on the PC).

When we try to compile and download a sample program, we get an error that "No communications link available to VEX Cortex robot).

Looking at the preferences, the only com port options are Automatic Selection and COM1. We are leaving in on Auto and hoping it sees COM3 or COM4 but it doesn't seem to be.

I should also mention that the microcontroller has the following lights:
Robot: flashing yellow
VEXnet: solid yellow
Game: flashing between red and yellow

We would greatly appreciate any suggestions on what we might be doing wrong or might need to do to get a connection established. We have students who have written programs that they are anxious to try.

Thanks!

Brad


Wed May 02, 2012 7:12 am
Profile
Moderator
Moderator
User avatar

Joined: Tue Sep 14, 2010 9:19 pm
Posts: 496
Post Re: Driver/Connectivity Issue?
I don't know what's causing your problem, but until someone who does comes along, let's see if I can help. First of all, here's a handy chart for deciphering the LED flash codes: http://content.vexrobotics.com/docs/VEX ... 081811.pdf
Now, here's a vague checklist I would run through:
Did you try to download the firmware? Does it work?
How are you trying to download your programs? Directly from the computer to the Cortex through the USB-USB cable, or through the joystick?
What download method are you using? It's under Robot -> Vex Cortex Download Method.
Have you tried a different cable?

See if one of those things is your problem, then we can continue debugging.
A couple versions ago, the "no communication" type errors were terrible, because if nothing else was wrong, it meant sitting there and using the IFI bootloader to reset the firmware, and then praying for the download bar to hit 100% without crashing.

_________________
sudo rm -rf /


Wed May 02, 2012 10:33 am
Profile
Rookie

Joined: Wed May 02, 2012 6:59 am
Posts: 2
Post Re: Driver/Connectivity Issue?
It turns out everything was working fine. We just were using the proper order of operations to get the firmware downloaded, etc.

Thanks for your response.


Thu May 03, 2012 8:47 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.