ROBOTC.net forums
http://www.robotc.net/forums/

Bootload failed; Device ID verification failed
http://www.robotc.net/forums/viewtopic.php?f=11&t=3343
Page 1 of 1

Author:  leilisms [ Wed Jun 22, 2011 6:43 pm ]
Post subject:  Bootload failed; Device ID verification failed

Beginner robotC programmer.
Working with a robot (similar to squarebot) previously programmed with EasyC.
Attempting to download RobotC Firmware onto the VEX for IFI opens the "loading" window at 0%, getting message "Bootload failed: Device ID verification failed"

Any advice/help/fix? I'm completely lost and trying to learn RobotC, but I can't program until I can get the firmware onto the robot!
Thanks to all!

Author:  vnguyen [ Thu Jun 23, 2011 10:17 am ]
Post subject:  Re: Bootload failed; Device ID verification failed

What version of ROBOTC are you using?

Author:  leilisms [ Thu Jun 23, 2011 1:41 pm ]
Post subject:  Re: Bootload failed; Device ID verification failed

I'm using RobotC for Cortex and PIC 2.32
I recently tried to load the drivers with a different VEX microcontroller, and had the same problem.
Also attempted to revert the VEX to the original factory code using the "VEX Default Firmware" found here and the IFI Loader.
The right port was used, controller verification done, but I receive the error "Unknown Device id (0)"

Author:  jbflot [ Thu Jun 23, 2011 2:07 pm ]
Post subject:  Re: Bootload failed; Device ID verification failed

Hi Leilisms,

Are you trying to program the original VEX 0.5 PIC or the newer VEX 2.0 Cortex? In either case, ROBOTC for Cortex and PIC can be used to program both controllers, so you want to make sure you have ROBOTC configured appropriately. Under the Robot menu, select Platform Type, and then choose the appropriate controller.

Hope that helps!

Author:  leilisms [ Sun Jun 26, 2011 3:31 pm ]
Post subject:  Re: Bootload failed; Device ID verification failed

HI jbflot!

I'm using RobotC to program VEX 0.5 PIC, and I've already set the platform to the correct option.

Author:  jbflot [ Mon Jun 27, 2011 11:58 am ]
Post subject:  Re: Bootload failed; Device ID verification failed

A few things to check:

- Have you successfully installed the drivers for the USB-to-Serial Programming Cable? You can find them here: http://www.robotc.net/download/cortex/
- If you go to View > Preferences > Detailed Preferences... it will open a Preferences window. On the Platform Tab, make sure the "Prolific USB to Serial" option is selected as the Communications Port.
- Make sure you download the Master CPU Firmware before downloading the ROBOTC Firmware.
- Make sure your battery is fully charged and connected, with the VEX turned on.
- We've got free tutorial videos that may help, found here: http://www.robotc.net/vex_full/ in the Setup section.

Author:  leilisms [ Tue Jun 28, 2011 1:59 am ]
Post subject:  Re: Bootload failed; Device ID verification failed

Checked all, and;

-Programming Cable drivers, fully installed
-Correct platform selected
-Master CPU Firmware downloads/installs without a hitch

Still get the same problem.
I've uninstalled/reinstalled RobotC itself, and nothing has changed. Tomorrow I will be trying a different programming cable, and perhaps a different computer as well, if I can.

Author:  jbflot [ Fri Jul 01, 2011 9:28 am ]
Post subject:  Re: Bootload failed; Device ID verification failed

For what it's worth, I just retested downloading the Master and CPU Firmware to the PIC in ROBOTC 2.32. It downloaded successfully.

I have seen that some PICs wear out over time, and will occasionally fail to download code, though they don't usually return that error message. In these cases what often works is hooking up the 9.6V Transmitter battery and trying again.

Hope that helps.

Author:  leilisms [ Fri Jul 01, 2011 9:58 pm ]
Post subject:  Re: Bootload failed; Device ID verification failed

It seems that I've found the problem!

Yesterday I tried a different programming cable, and it failed yet again, but after trying a third, it seemed to have worked.
Using the third cable I can download the firmware without a hitch and compile/download a sample program.
I do not have the third programming cable with me at the moment, so I am unable to completely confirm that it works today, but it downloaded during 3 separate trials yesterday, so I assume that it is working!

Thank you very much for all your help!

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/