View unanswered posts | View active topics It is currently Thu Aug 21, 2014 12:40 pm






Reply to topic  [ 3 posts ] 
Debugger problems? Compile and Download Problems 
Author Message
Rookie

Joined: Mon May 02, 2011 10:51 pm
Posts: 6
Post Debugger problems? Compile and Download Problems
I hope someone can help us out. When we interface with the cortex, everything is fine in the debugger window. The wiring is correct, the firmware is correct, as far as we can see every thing is correct. When we compile and download everything is good. Then we run the program, the debugger window shows that the motor is running at a speed of 63 for 5 sec. and then stops. But, nothing every moves.

This is not a problem specific to one machine, it is effecting about 50% of the participants.

Any help will great!

Thanks, we are in the middle of a teacher training and having many problems. thanks for any help.

Phil Winegar and Bill Lewis (PLTW Master Teachers)
Colorado Springs.


Mon Jun 27, 2011 2:45 pm
Profile
Site Admin
Site Admin

Joined: Mon Jun 08, 2009 4:50 pm
Posts: 70
Post Re: Debugger problems? Compile and Download Problems
This may seem obvious but really isn't-- is the robot turned on? The cortex lights up and gets power to run the board via the USB but does not have enough power to run motors and most sensors until a battery is connected and the power is switched on via the mechanical switch on the front of the Cortex.

_________________
Bence Feher

Undergraduate Intern - NREC, Robotics Academy
ROBOTC - Testing/Documentation/Developer

Computer Science, Japanese, East Asian Studies
University of Pittsburgh, Konan University 甲南大学


Mon Jun 27, 2011 3:37 pm
Profile
Site Admin
Site Admin

Joined: Tue May 15, 2007 9:02 am
Posts: 405
Post Re: Debugger problems? Compile and Download Problems
Also double-check that you're not trying to run 2-wire motors plugged directly into the 3-wire ports. 2-wire motors must be plugged into MOTOR Ports 1 and 10, or 2-9 using one of the motor controller cables. Feel free to copy the code to the forum for us to take a look.

_________________
Jesse Flot
CMU Robotics Academy
ROBOTC Support


Fri Jul 01, 2011 9:32 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.