ROBOTC.net forums
http://www.robotc.net/forums/

Can't download anything to robot - HELP!
http://www.robotc.net/forums/viewtopic.php?f=11&t=1768
Page 1 of 1

Author:  atop50 [ Wed Jul 22, 2009 8:52 pm ]
Post subject:  Can't download anything to robot - HELP!

I am rather familiar with the ROBOTC program and have used it successfully in the past.

As the subject suggests, I am unable to download anything to the robot, thus rendering the entire program useless. :breakcomputer:

I am certian that my cable is set up and working properly.


I sometimes get a message saying "Failed to erase flash memory" then ROBOTC stops responding, other times It just stops responding without a message.

Any help would be great.

Author:  vnguyen [ Thu Jul 23, 2009 8:32 am ]
Post subject:  Re: Can't download anything to robot - HELP!

What version of ROBOTC for IFI are you running? 1.40?

A few things you can try:

[*]Try downloading the Master Firmware (by going to the "Robot" menu) to the robot (if it lets you), and then afterward re-downloading the ROBOTC Firmware.

[*]Otherwise, try different USB ports

[*]Try downloading ROBOTC to a different computer, and seeing if it lets you communicate to the robot.

Let me know how it goes.

Author:  atop50 [ Thu Jul 23, 2009 11:38 am ]
Post subject:  Re: Can't download anything to robot - HELP!

Thanks for the suggestions.

I am running version 1.40.

I had already tried downloading the master firmware, and that's when I got the message saying "Failed to erase flash memory"

I have also tried different USB ports, without success.

As I understand, ROBOTC can only be used on PCs (please correct me if I'm wrong) and, unfortunately, this is the only PC in the house.

Another question, what does the button on the USB to serial controller module do?

Based on the message and the fact that one of the robot's motors "twitches" when I try to download something, I think that the computer is able to communicate with the robot, but the the program "ROBOTC for IFI 1.40" stops working/responding shortly after the connection is established,

Would re-installing ROBOTC fix this problem?

If so, how do I activate the program once I install it (I only have a single user license)?

Thanks.

Author:  vnguyen [ Thu Jul 23, 2009 12:08 pm ]
Post subject:  Re: Can't download anything to robot - HELP!

When you uninstall ROBOTC, your PC will still know that ROBOTC is activated on your computer and you will not have to activate again (unless you format your hard drive). You can try uninstalling ROBOTC, and re-installing it. You can also try re-installing the USB-to-Serial adapter drivers while you're at it.

Let me know if you still have issues.

Author:  atop50 [ Thu Jul 23, 2009 3:13 pm ]
Post subject:  Re: Can't download anything to robot - HELP!

Well, I uninstalled ROBOTC and it turned out I had both version 1.08 and 1.40 installed. I after getting rid of both, I successfully downloaded version 1.40 from robotc.net. I also uninstalled the driver for my USB-to-serial cable, but could not re-install it. When I connected the cable after uninstalling the driver, windows claimed to have successfully installed the driver again, but when I opened device manager to confirm, it said "A service installation section in this INF is invalid." and there where no ports to select from in the ROBOTC preferences.

So, ROBOTC should be working, but the cable is messed up now.

Also, I noticed that when I tried to set the cable's port in device manager, all of the ports that I had previously set where "in use". I know this is not true, is there any way to fix this?

Thanks for all the help so far.

Author:  vnguyen [ Thu Jul 23, 2009 3:27 pm ]
Post subject:  Re: Can't download anything to robot - HELP!

Good find. That would definitely do it. ROBOTC can only have a single installation.

As far as the driver install, I'm curious if you tried restarting after you uninstalled the driver? I'm wondering if Windows is holding onto something that it needs to unload before you re-install. It's not typical, but something may just be up with the pc.

Author:  atop50 [ Thu Jul 23, 2009 4:36 pm ]
Post subject:  Re: Can't download anything to robot - HELP!

Originally I did not restart after uninstalling the driver. I uninstalled it again and then restarted, but I still got the "A service installation section in this INF is invalid" message.

Thanks again.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/