View unanswered posts | View active topics It is currently Sun Aug 31, 2014 3:28 am






Reply to topic  [ 3 posts ] 
RobotC 1.52 Beta Program Upload 
Author Message
Rookie

Joined: Tue Mar 18, 2008 7:11 pm
Posts: 22
Location: San Antonio, TX
Post RobotC 1.52 Beta Program Upload
Howdy All,

I'm working with one of the local colleges with their upcoming robotics competition and they are using RobotC 1.52 Beta. I've update the Master Firmware to V8 and the User Code to 766 using IFI Loader and that works like a champ.

However, when I try to do anything in RobotC that requires access to the robot over the com port, it just hangs forever. The Test Messaging Performance page show message 'Checking robot controller for response'. I get the same message with the Compile and Download option.

Am I missing a critical step or is there actually a bug somewhere?

... Added ...
Watching the communications Message Log when attempting to open the comm port (10) from within RobotC.

Comm Message Log:
48.507 Baud rate set to 115.2K. Parity to 'None'.
48.611 Baud rate set to 115.2K. Parity to 'None'.

... Added some more ...
Okay, on a whim I decided to give my Windows 7 Beta a try with the download. Loaded the VISTA Prolific Driver (took two tries, error on the first time with an empty error dialog). Cranked up RobotC 1.52 Beta and updated the Master and User firmware with no problems. Downloaded one of the sample programs with no problems.

So, there must be an issue my install of Vista/RobotC. I'll try to remove / re-install later this week.

D. Sean Kelly


Mon Apr 20, 2009 10:29 pm
Profile
Site Admin
Site Admin

Joined: Wed Jan 24, 2007 10:44 am
Posts: 439
Location: Pittsburgh, PA
Post Re: RobotC 1.52 Beta Program Upload
Thanks for the note, I'll pass this onto the dev team to see what the issue is.

_________________
Vu Nguyen
Software Training Development Team | Webmaster
Need more support? Use the ROBOTC Ticketing system

Robotc.net| Robomatter Store | Robotics Academy | CS2N


Tue Apr 21, 2009 8:26 am
Profile
Rookie

Joined: Tue Mar 18, 2008 7:11 pm
Posts: 22
Location: San Antonio, TX
Post Re: RobotC 1.52 Beta Program Upload
Just got time to play with this again. I removed RobotC for IFI (1.54 Beta now); removed all the directories that were left hanging (e:\program files\....)

Re-installed, cranked up RobotC and attempted to access the different options that would either download a program, update the firmware, update user program, debugger, and test message link menu options; essentially, any option that attempts to access the serial port.

I'm not getting any error messages the application just hangs indefinitely and the program has to be 'terminated' in order to close.

I'm certain that the serial-usb comm cable is functioning properly because I can update the firmware using IFI_Loader and the same cable works fine with RobotC 1.54 beta on my laptop (under Windows 7 RC!).

Using a terminal emulator I can see the VEX startup with:
IFI>
Master: 8
User: 768

I'm at a loss as to what step to take next. I have had versions of RobotC from before 1.40 installed/removed from this system and I have RobotC for Mindstorms as well.

Is there any other system files that may be sitting somewhere other than c:\program files\robotics academy\robotc for ifi\* directory that may need to be replaced or removed?

Sean


Sun May 17, 2009 11:55 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.