Selected COM Port Is Unavailable
Page 1 of 1

Author:  mpitt [ Wed Sep 02, 2015 2:50 pm ]
Post subject:  Selected COM Port Is Unavailable

Hi Everyone,

I was searching around but couldn't find an answer to this problem we've run into. This year we upgraded to RobotC Version 4 from 1.8 I believe, and when our robot is connected to the computer the port shows up as Prolific USB-to-Serial Comm Port in Device Manager. Inside RobotC when trying to download to the robot the port shows as Offline if the Allow Any Ports option is unchecked, but available if it is. After I select the port and click OK it says "Selected COM port is not available. Check that your device is connected to the PC. Please select a COM port." I've tried restarting, re-installed the usb driver and restarting after that but still get nothing. I made sure the Firmware Updater is not running and have tried different platforms in the Robot menu just in case that was the issue. Hopefully there is something easy I'm not seeing, but any help is appreciated.

Forgot to add, the robot is the Vex V.5 if that makes a difference.

Author:  Tabor473 [ Sun Nov 08, 2015 5:44 pm ]
Post subject:  Re: Selected COM Port Is Unavailable

So ROBOTC version 4.xx does not support the VEX PIC Microcontroller(V0.5) seen here

If you are still running the VEX PIC Microcontroller I would suggest ROBOTC 3.63 found here.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group