View unanswered posts | View active topics It is currently Tue Sep 22, 2020 4:48 pm

Reply to topic  [ 2 posts ] 
I cant get my cortex to update 
Author Message

Joined: Mon Jan 19, 2015 10:04 pm
Posts: 2
Post I cant get my cortex to update

So I have a vex cortex which I was trying to update to the latest firmware but my windows 7 laptop does not recognize the USB device and RobotC cant see anything plugged into a COM port. Here is the procedure I followed:

1. Plug battery into the cortex
2. Plug USB A-to-A Cable into the cortex
3. Switch off the cortex
4. Hold the Config Button
5. Plug USB into the computer
6. Wait for all 3 lights on the cortex to turn green
7. Release the Config Button

Windows then makes that "Do-Do" sound and then it says the USB device is not recognized, and RobotC does not find anything when I go to view->Select Communications Port

Now if Instead I simply turn the Cortex ON and plug the USB cable into the computer without touching the Config Button, The computer recognizes the USB as the cortex on COM 12. I tried simply running the Cortex firmware update by going to Robot->DownloadFirmware->ManuallyUpdateFirmware->MasterCPUFirmware->StandardFile

It seemed to initially do the update just fine, but when it got to "Entering Master CPU Mode" the Robot light started blinking green and Windows Stopped recognizing the USB device again, and now it acts exactly like in the first scenario but without having to hold the config button.

Is there something I did wrong? Is there another driver I need to install? I installed the Universal Driver for windows 7 and that doesn't seem to have had any sort of effect.

Any help would be appreciated!

Thank you

P.S. installing the ROBOTC Firmware seems to go just fine. I'll just use this spare cortex with old CPU firmware and updated robotc firmware until I hear back

EDIT: It seems I am having the exact same problem with the Joystick Firmware. The Robot Light is Flashing and Windows does not recognize the USB device after trying to update the firmware.

Mon Jan 19, 2015 10:24 pm

Joined: Mon Jan 19, 2015 10:04 pm
Posts: 2
Post Re: I cant get my cortex to update
Well, the Issue appears to be my laptop. There must be some conflicting Drivers or something. I ran the firmware update on my home desktop and everything ran just fine.

Tue Jan 20, 2015 12:58 am
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.