View unanswered posts | View active topics It is currently Mon Dec 22, 2014 6:56 pm






Reply to topic  [ 2 posts ] 
waitUntilMotorStop - problem 
Author Message
Rookie

Joined: Tue Jul 29, 2014 3:07 pm
Posts: 8
Post waitUntilMotorStop - problem
This summer I have been working with the program for EV3, and I have used a lot of "waituntilmotorstop"s. However, now I have downloaded the update and it gives me an error when playing the code on the robot, as if this function didn't work well.

The message I get when I use the "waituntilmotorstop" function is:

Quote:
Exception Error in User Program:

Exception Type: 'Invalid opcode(75)'

Program Slot: 0, Task ID: main[0]
Error at PC: lectura_cara+0x0028
Task PC: lectura_cara+0x001D,
TaskState: 'Exception'


Exception Details: Opcode 0x07



How can I solve this, appart than using a simple wait? I hope this is not the unique solution as I have a lot of "waituntilmotorstop"s in the code...


Sat Nov 22, 2014 5:17 pm
Profile
Rookie

Joined: Tue Jul 29, 2014 3:07 pm
Posts: 8
Post Re: waitUntilMotorStop - problem
Nothing, it has already been solved. A firmware or kernel update was needed. For a time I had gone mad


Sat Nov 22, 2014 6:15 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.