ROBOTC.net forums
http://www.robotc.net/forums/

NXT Beeps when running auto program
http://www.robotc.net/forums/viewtopic.php?f=1&t=6937
Page 1 of 1

Author:  DrTechDaddy [ Thu Oct 10, 2013 4:41 pm ]
Post subject:  NXT Beeps when running auto program

I tried a variation of the programs from the recent Hangout webinar. My auto program runs OK but the NXT keeps beeping rapidly while the program runs. It ran OK the first time with just auto loaded, but when I tried loading a teleop program and running auto again, I got many problems, including the beeping, so I reset the teleop program name to No Teleop Program, but the beeping continues.
This was my first attempt running RobotC.
Running RobotC 3.62 on Windows 7HP SP1
Since we don't have our Matrix robot wired yet, i set the config for 2 motors on NXT ports BC, and set the Matrix config to default.
I'm using compile and download to start the debugger and run the auto program by clicking Autonomous Ready then Autonomous Running in the Joystick Control window.
Also, how is it possible to re-run the program without repeating the compile and download?

Author:  DrTechDaddy [ Thu Oct 10, 2013 4:54 pm ]
Post subject:  Re: NXT Beeps when running auto program

I think I have a partial answer to my own question. It seems when trying to resume communications, I may have accidentally clicked the Audible Feedback checkbox in the joystick control window. In any evert, the program is now reliably restarting. So I'm heading to the web to learn more about "audible feedback" and the debugger windows in general.

Author:  Ernest3.14 [ Thu Oct 10, 2013 9:43 pm ]
Post subject:  Re: NXT Beeps when running auto program

The beeping indicates when the robot gets a packet of data from the computer. The more closely spaced the beeps, the more reliable your link is - this is important if you're trying to debug whether or not your wireless signal is reliable or not.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/