View unanswered posts | View active topics It is currently Fri Apr 18, 2014 10:50 am






Reply to topic  [ 4 posts ] 
RobotC does not know what writeToDebugStream is? 
Author Message
Rookie
User avatar

Joined: Thu Sep 13, 2012 8:35 pm
Posts: 3
Post RobotC does not know what writeToDebugStream is?
Hello everyone,
I have recently had something happen which I can not find the reason for why it is happening?
I am getting the error
Code:
**Error**:Undefined procedure 'writeToDebugStream'.

This what my code looks like:
Code:
#pragma config(Hubs,  S1, HTMotor,  HTMotor,  HTMotor,  none)
#pragma config(Sensor, S2,     gyroSensor,     sensorI2CHiTechnicGyro)
#pragma config(Sensor, S3,     lightSensor,    sensorLightActive)
#pragma config(Sensor, S4,     sonar,          sensorSONAR)
#pragma config(Motor,  motorA,          motorhand,     tmotorNXT, PIDControl, encoder)
#pragma config(Motor,  motorB,          motorwrist,    tmotorNXT, PIDControl, encoder)
#pragma config(Motor,  mtr_S1_C1_1,     motorRightF,   tmotorTetrix, openLoop, encoder)
#pragma config(Motor,  mtr_S1_C1_2,     motorLeftF,    tmotorTetrix, openLoop, reversed, encoder)
#pragma config(Motor,  mtr_S1_C2_1,     motorRightR,   tmotorTetrix, openLoop, encoder)
#pragma config(Motor,  mtr_S1_C2_2,     motorLeftR,    tmotorTetrix, openLoop, reversed, encoder)
#pragma config(Motor,  mtr_S1_C3_1,     motorScissorR, tmotorTetrix, openLoop, encoder)
#pragma config(Motor,  mtr_S1_C3_2,     motorScissorL, tmotorTetrix, openLoop, encoder)
#pragma DebuggerWindows("debugStream");
#include <Config.c>

task main()
{
   writeToDebugStream("Starting to move forwards to setup for left turn towards ring zone...\n");
   init();
   writeToDebugStream("Move forwards function completed!  Now starting to turn left towards ring zone...\n");
   turnLeftTowardsZone();
   writeToDebugStream("Now facing towards ring zone!");
}

P.S. Tried all of the targets (Physical Robot, PC Emulator, and Virtual Worlds) to see if that was a problem. I also restarted robotC and computer.
Please help any comment or Idea is welcomed!


Wed Jun 19, 2013 4:56 pm
Profile
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 534
Post Re: RobotC does not know what writeToDebugStream is?
Make sure you are using the writeDebugStream command and not the writeToDebugStream command; the extra 'To' added into the command is why you are seeing the error.

_________________
Check out our Blog! And our Facebook page!
Need help? Take a look at our Wiki and our Forums.

I just met you,
And this is crazy,
But here's my code now,
So fix it, maybe?
~ Carly Rae Jepsen parody


Thu Jun 20, 2013 2:29 am
Profile
Rookie
User avatar

Joined: Thu Sep 13, 2012 8:35 pm
Posts: 3
Post Re: RobotC does not know what writeToDebugStream is?
Thank you, everything works great now.


Thu Jun 20, 2013 10:53 am
Profile
Expert
User avatar

Joined: Fri Nov 02, 2012 12:07 am
Posts: 164
Location: California, USA
Post Re: RobotC does not know what writeToDebugStream is?
Yeah, syntax errors are common and quite the devils. :D

_________________
string Robored = "Awesome"
~~Neil Balch~~


Sat Aug 03, 2013 12:13 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.