View unanswered posts | View active topics It is currently Tue Aug 11, 2020 12:38 pm

Reply to topic  [ 3 posts ] 
[HELP!!] Robotc Stop Working When Adding License 
Author Message

Joined: Thu Feb 21, 2013 2:11 am
Posts: 2
Post [HELP!!] Robotc Stop Working When Adding License
I purchased the license for Lego NXT this week.
But I encountered problem that programme stop working after I entered the license ID and password and "activate online".

I tried to fix the problem by reinstalling the Robotc programme as well as the LEGO driver. The problem still exists!

Anyone help?

1.png [ 243.61 KiB | Viewed 8147 times ]
2.png [ 231.99 KiB | Viewed 8147 times ]
3.png [ 259.15 KiB | Viewed 8147 times ]
Thu Feb 21, 2013 2:23 am
Site Admin
Site Admin

Joined: Thu May 24, 2012 12:15 pm
Posts: 722
Post Re: [HELP!!] Robotc Stop Working When Adding License
It looks like ROBOTC may not have been able to write the activation data to the registry properly; to solve this, you will need to uninstall ROBOTC, clear out its registry values, and then reinstall ROBOTC.

First, navigate to the Windows Control Panel and uninstall ROBOTC; this works the same as uninstalling any other program.

*WARNING: The next step involves the Windows Registry Editor; please follow these steps precisely to avoid causing further problems with the computer.*
*If you are unsure of any steps or uncomfortable performing these steps, have your IT Department (if applicable) do this for you *

Next, open the Windows Start menu and type 'regedit' into the search field; this should bring up regedit.exe, which you will then want to open. Once the Registry Editor has opened, navigate to the 'HKEY_CURRENT_USER -> Software -> Robotics Academy' folder, right click on the ROBOTC folder, and select the 'Delete' option. This will delete ROBOTC's registry values.


Finally, download and install the latest version of ROBOTC from our website (, which will then allow ROBOTC to rewrite the registry values for you.

If you are experiencing a licensing issue after this, please send in at ticket via ( and we will be more than happy to help you resolve the issue.

Check out our Blog! And our Facebook page!
Need help? Take a look at our updated help documentation and the ROBOTC Forums.

Thu Feb 21, 2013 2:02 pm

Joined: Thu Feb 21, 2013 2:11 am
Posts: 2
Post Re: [HELP!!] Robotc Stop Working When Adding License
:bigthumb: :bigthumb: :bigthumb: :bigthumb: :bigthumb: :bigthumb: :bigthumb:
Really thanks for the help!!!

I initially tried the exact same steps according to your instruction.
It failed.
HAHA, I didn't give up.
Tried again with slightly differences.

- After unistallation of ROBOTC for Mindstorm, I deleted the ''Robotics Academy'' Folder.

- I reinstalled the ROBOTC for Mindstorm as admin, not simply click to install the software.

It works ! :bigthumb: :biggrin: :D :-) :P :wink:

So happy! Thank you !

Fri Feb 22, 2013 1:31 am
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.