ROBOTC.net forums
http://www.robotc.net/forums/

Controlling motor speed without losing power
http://www.robotc.net/forums/viewtopic.php?f=1&t=4248
Page 1 of 1

Author:  RTO [ Tue Feb 14, 2012 4:47 pm ]
Post subject:  Controlling motor speed without losing power

Is it possible to run a motor very slowly without losing motor power. We are attempting to lift an arm with tele-op but movement is very irratic - way too fast. However when we slow the motor power down by division, we lose power and cannot lift the arm. Any suggestions?

Author:  magicode [ Tue Feb 14, 2012 5:09 pm ]
Post subject:  Re: Controlling motor speed without losing power

Ideally, you would gear it down. Is that a possibility in your case?

Author:  RTO [ Wed Feb 15, 2012 10:01 am ]
Post subject:  Re: Controlling motor speed without losing power

Thanks. It is geared down some based on gears we have on hand. Didn't know if there was a way to slow it down otherwise. I will check to see how fast we can get other gears in.

Author:  magicode [ Wed Feb 15, 2012 10:45 am ]
Post subject:  Re: Controlling motor speed without losing power

Honestly, there's no other way to do it if you're not getting any lift at significant motor values. Setting the motor at a lower value slows it down by giving it power less frequently. This means that it has less torque. If it's too fast at full speed, you could try very careful calibration to find middle ground. PID control only works if it has room to lay with. What motor power ranges are you getting lift in?

Author:  RTO [ Wed Feb 15, 2012 1:20 pm ]
Post subject:  Re: Controlling motor speed without losing power

Thank you. Full power lifts, divided by 2, 3, 4 works. I believe 10 works. Divided by 18 does not. Interestingly, once we actually got the arm to work smoothly at divided by 3. But I noted that the radio button in the teleop program was lit for both autonomous and teleop simultaneously. But, we cannot repeat this setting and hence cannot repeat the performance. Are we not understanding something about the set up?

Author:  magicode [ Wed Feb 15, 2012 1:35 pm ]
Post subject:  Re: Controlling motor speed without losing power

RTO wrote:
Thank you. Full power lifts, divided by 2, 3, 4 works. I believe 10 works. Divided by 18 does not. Interestingly, once we actually got the arm to work smoothly at divided by 3. But I noted that the radio button in the teleop program was lit for both autonomous and teleop simultaneously. But, we cannot repeat this setting and hence cannot repeat the performance. Are we not understanding something about the set up?

Are you dividing full power (a value of 100) by those numbers listed? If there's any kind of force on the arm, there's no way a motor power of 5 would lift things unless it was geared like crazy. I'm surprised a motor power of 10 lifted anything. If this is the case, then I retract my original statement: A control loop will have plenty of room to maneuver in. I suggest looking into proportional loops or PID loops. You can find great examples for both on these forums.

Author:  RTO [ Thu Feb 16, 2012 10:37 am ]
Post subject:  Re: Controlling motor speed without losing power

Did a search for both of these on the forum. Found a lot of stuff I will have to sort through. Can someone point me in the right direction?

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/