ROBOTC.net forums
http://www.robotc.net/forums/

cannot get gyro to reset
http://www.robotc.net/forums/viewtopic.php?f=1&t=19549
Page 1 of 1

Author:  joetrotter [ Thu Jan 26, 2017 1:29 pm ]
Post subject:  cannot get gyro to reset

I have used the mindstorms for many years with RobotC 3.x but am now replacing class set with EV3's. I was trying out the gyro with sensorType[S2 ] = sensorEV3_Gyro. It sets up fine on the debug window and I can step thrugh the sensorType and watch the degrees changing. When I try to reset it with resetGyro(S2)and I step through, the mode is "angle" when it sets the type. i can turn the gyro and see the angle changing on the debug window. When i step through resetGyro(S2) Mode changes to "rate and angle" and the value goes from ex. 20 to -20 not 0. I also tried sensorReset(S2) same result. BUT if I put both resetGyro(S2) AND sensorReset(S2) the value resets to 0 after whichever is second.

Where am I going wrong? I went to the help, but only online help works. Help does not work from within RobotC. Found no ideas with online help .

Thanks for any help,
Been using RobotC since the early days. LOVE it.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/