View unanswered posts | View active topics It is currently Wed Nov 22, 2017 6:09 pm




View unanswered posts

Search 
   Topic Preview  Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic.   We are having an issue with connecting EV3 with Robot C ( License purchased for both Robot C and Virtual World). The Robot> Compiler Target menu , defaults to Virtual World , and the option to set it to Physical Robot is disabled. Need some advise to set this up correctly asap. Thanks Robot Compiler Target defaults to VW and PR is disabled

in ROBOTC for LEGO MINDSTORMS

22ams

0

4895

Sun Sep 27, 2015 1:43 pm

22ams View the latest post

There are no new unread posts for this topic.   When I use the gyro to turn a specific degree it is off. Is there a way to recalibrate the gyro so it is spot on? Recalibrating the gyro sensor

in ROBOTC for LEGO MINDSTORMS

techlane

0

4852

Fri Sep 25, 2015 11:35 am

techlane View the latest post

There are no new unread posts for this topic.   I have updated from 4.3 to 4.5. I am now getting loads of errors and my physical robot is unresponsive. I want to revert back to 4.3 because our 1st competition is only 3 weeks away and I don't have time to mess with the code...we need time to practice! How can I get the old version back? want to go back to v4.3

in ROBOTC for VEX IQ

robotmom

0

6276

Thu Sep 24, 2015 9:52 am

robotmom View the latest post

There are no new unread posts for this topic.   I'm using version 4.5 for Lego Mindstorms with NXT brick and Tetrix motors and controller and software running under Windows 10. The TurnLeft/TurnRight functions do not work. Some motor functions work using the timing and speed parameters (I do not have the encoders for the Tetrix motors), but these functions don't. Why is that? Not only do they not work, but the code does not run past the first time these functions are called. And yet, I get no error messages. Problem with left/rightTurn in graphical Robotc 4.5

in Issues and Bugs

Bushedo

0

6153

Tue Sep 22, 2015 3:35 pm

Bushedo View the latest post

There are no new unread posts for this topic.   I wonder About function sendI2CMsg and readI2CReply in ev3! How to use? Could you give me hum example? OR inform the place, Where HAVE a detailed explanation? Thanks in advance! Function sendI2CMsg and readI2CReply in ev3

in ROBOTC for LEGO MINDSTORMS

CrisHaas

0

4655

Tue Sep 15, 2015 6:33 pm

CrisHaas View the latest post

There are no new unread posts for this topic.   This is a total newbie question, but I'm trying to figure out what would be needed to get an FLL class off the ground. Some of this stuff I'm coming across for the first time. Can someone explain to me why/if it's necessary to have the Virtual Brick? Would it not be sufficient to just use RVW with the ROBOTC IDE? Is the Virtual Brick more for just programming directly on the brick itself? Is that recommended over programming just using the ROBOTC IDE? Am I totally just asking nonsensical... Robot Virtual World with ROBOTC/Virtual Brick

in General Discussions

blevins

0

5083

Tue Sep 15, 2015 12:33 pm

blevins View the latest post

There are no new unread posts for this topic.   Want to earn a spot at VEX Worlds 2016? Join us tomorrow, Wednesday, September 9th, at 7:00 pm ET for a discussion on using ROBOTC and Robot Virtual Worlds to prepare for VEX competitions. In this interactive webinar, we’ll explore: • The VEX and VEX IQ Programming Skills Challenge for Robot Virtual Worlds • How you can earn a spot at VEX Worlds 2016 with the Robot Virtual Worlds Competition • Robotics competition resources to help you out • Great tips on how you can incorporate virtual... Robot Virtual Worlds VEX Programming Skills Challenge!

in ROBOTC for CORTEX & PIC

JohnWatson

0

6943

Tue Sep 08, 2015 5:48 pm

JohnWatson View the latest post

There are no new unread posts for this topic.   Hi, I found a document about using and NXT brick whit a Hitechnic controler(for tetrix) Because we are begginers, we only have Ev3 bricks... So,Is it possible to use an EV3 brick whit a Hitechnic controler(for tetrix) whit your RobotC thank you :bigthumb: EV3 and Hi Technic

in ROBOTC for LEGO MINDSTORMS

nalfein

0

4903

Fri Sep 04, 2015 12:25 pm

nalfein View the latest post

There are no new unread posts for this topic.   Has anyone ever had any luck running an aquarium water pump on an arduino? I'm looking into using one to propel a floating device... like a small toy boat using my arduino and motor shield. Any help would be great. thanks water pump ran off an Arduino?

in ROBOTC for Arduino

tate2326

0

6607

Tue Sep 01, 2015 2:00 pm

tate2326 View the latest post

There are no new unread posts for this topic.   Version 4.50 with current firmware. This line of code causes my program to hang. What am I doing incorrectly. writeDebugStreamLine("%i:", SensorValue ); If I comment out this line, my program runs great. Thanks writeDebugStreamLine causes program to hang!

in Issues and Bugs

ronaldle

0

6055

Sat Aug 29, 2015 11:03 am

ronaldle View the latest post

There are no new unread posts for this topic.   I am using the RobotC ver. 4.50 with an EV3 robot. When I download sound files to the robot using the Download button on the File Management dialog, the files are downloaded to /home/root/lms2012/prjs/rc Is there a way I can download the files to: "/home/root/lms2012/resources/Sounds" instead? When I look at the Detailed Preferences dialog, I can see the option for "User Sound Files" on the Directories tab. When I browse for the folder and select it, the field is updated... Sound files (on the robot vs on the computer)

in Issues and Bugs

jkandra

0

6458

Fri Aug 28, 2015 11:32 am

jkandra View the latest post

There are no new unread posts for this topic.   RobotC 4.32, Vex IQ Windows 7 Today we tried to update the VEX IQ Brain firmware via the button on the ribbon. It is the button between "Save" and "Compile Program." We tried several Windows 7 laptops and a Windows 7 desktop machine, nothing worked. We changed batteries, VEX IQ brains and USB cables to see if the problem was outside of Robotc. We discovered that we could download the Firmware by going to: Robot: Download Firmware: Standard file As an aside that may not... Firmware download button does not work

in Issues and Bugs

kinnama

0

6271

Mon Aug 17, 2015 12:31 pm

kinnama View the latest post

There are no new unread posts for this topic.   I try to install the 64 bit Lego Mindstorms NXT USB driver on my Windows 7 laptop. This ends with the message: 'Installation ended prematurely because of an error'. Can anybody help me to tackle this problem? Driver install on 64 bit Windows 7

in ROBOTC for LEGO MINDSTORMS

marten

0

4626

Mon Aug 17, 2015 11:19 am

marten View the latest post

There are no new unread posts for this topic.   I was testing out the built in PID from robot C 4.0, the one with the check box under the Motor and Sensors setup, and was wondering if there was a way to see what motor power was actually being dumped into the motor, not just the motor power I passed into the PID machine. Actual motor power for robot c built in pid

in ROBOTC for CORTEX & PIC

chemicalcoal

0

5488

Mon Aug 10, 2015 11:00 pm

chemicalcoal View the latest post

There are no new unread posts for this topic.   Hey As the title says what is your hobby what do you do the things you like? What is your hobby?

in Off-Topic

Bernulf

0

5683

Thu Aug 06, 2015 11:01 am

Bernulf View the latest post

There are no new unread posts for this topic.   Hey guys I am a new member in this forum. My name is Bernard have 28 years and I come from Birmingham .) Hey

in Off-Topic

Bernulf

0

5658

Thu Aug 06, 2015 10:54 am

Bernulf View the latest post

There are no new unread posts for this topic.   So I tried reproducing this and I am unable to. I performed the following steps in robotC 4.32 Redownloaded Kernel and EV3 firmware with USB Changed Communication window to BT only Selected EV3 from list of bluetooth connections in Communication window Downloaded sample program onto robot Clicked Rename EV3 in the communication window Renamed EV3 to "Bananna" ( my go to throwaway name) Restarted EV3 Connections window does not have another robot with the same serial number. If the... Attachment(s) Phantom Robots (and names) in communication window

in ROBOTC for LEGO MINDSTORMS

Tabor473

0

1904

Tue Aug 04, 2015 10:27 am

Tabor473 View the latest post

There are no new unread posts for this topic.   How do elementary classroom students program their robots to navigate using their color sensor to stop within 1 inch of each of the specific colors? We noticed our robot see's green far away, red sometimes, and blue never. color sensor

in ROBOTC for VEX IQ

Chaback

0

6376

Tue Aug 04, 2015 7:00 am

Chaback View the latest post

There are no new unread posts for this topic.   So I've been playing with some PID controls lately when something happened to the controller that caused me re-upload the firmware. After doing so, the encoder stopped working, returning an overflow value of 2147483645. I'm not sure what's wrong and what caused the problem. Has anyone encountered this problem? Need help urgently !!! Overflow Problem with Encoder...

in ROBOTC for CORTEX & PIC

XineedanIDnow

0

4922

Mon Aug 03, 2015 2:36 am

XineedanIDnow View the latest post

There are no new unread posts for this topic.   I recently purchased Pixycam adapter from Mindsensors and I'm testing it with Xander's drivers. Anyone knows the value to enter to scale the blobs size from cam(I don't know cam resolution) to EV3 display? Mindsensors Pixycam Adapter

in ROBOTC for LEGO MINDSTORMS

giuseppe.fava

0

4839

Wed Jul 29, 2015 6:07 am

giuseppe.fava View the latest post

There are no new unread posts for this topic.   Hello, I am using RobotC software version 4.32 and am attempting to download code to a Vex IQ robot controller/brain that has recently been updated to V1.15 firmware. We've successfully done this on another brain and, for some reason, are having problems repeating it on two other brains. We can't figure out why it works for one brain but not the others. Please see the character log when we try to download a program into the brain (below). Thanks in advance for any help you can provide!!!... Getting Error: Failed to Verify the Serial Link is Connected

in ROBOTC for VEX IQ

Hazim

0

7044

Mon Jul 27, 2015 9:33 pm

Hazim View the latest post

There are no new unread posts for this topic.   Hello ! I am feeling extremely glad to enter into this technology world. Being in the field of information technology as technology lead for various programming languages like C, C++, Ruby, PHP, Java, etc., I am really excited to be the part of this social technology community. I hope it would be an another learning experience for me in this forum community, as I am looking forward to interact with the esteemed members of this technology world. It also giving me an opportunity to share my own... Happy to Help with Robotics Developers Forum

in General Discussions

ranjeet

0

3565

Wed Jul 22, 2015 7:48 am

ranjeet View the latest post

There are no new unread posts for this topic.   When I compile and download to my robot, I always get the program debug window. How do I turn this behavior off. I have looked in the preference and advance preference tabs and I do not see an option to turn it off. My program works so I don't need to see the window. program debug window

in Issues and Bugs

ronaldle

0

4345

Mon Jul 20, 2015 11:12 am

ronaldle View the latest post

There are no new unread posts for this topic.   Hi, I am trying to download some additional sound files to the EV3. When I do, they go into the rc directory on the EV3, rather than the sound directory. And then the program doesn't find them. I suspect I've overlooked something. I've looked around on the menus for a place to set the target, but don't see anything. Any ideas or suggestions are appreciated. Thanks. Howard Downloading Sound Files

in ROBOTC for LEGO MINDSTORMS

tabbycatrobots

0

2866

Tue Jul 14, 2015 9:18 am

tabbycatrobots View the latest post

There are no new unread posts for this topic.   On Robotc start page, when I click on any link under the resource link, IE starts up. I do have my default program set to Chrome and the files .htm and .html default is Chrome. How can I get robotc to start Chrome instead of IE. Thanks Use Chrome instead of IE.

in ROBOTC for CORTEX & PIC

ronaldle

0

2672

Tue Jul 07, 2015 10:56 am

ronaldle View the latest post

There are no new unread posts for this topic.   New to RobotC. Setting up my motors. ON a VEX ARM® Cortex. Unless I have somethign configured wrong, the choices don't list my motors. They are 2-wire DC motor e.g. VEX part 276-1610 Is there a way to add my motors to the list? Motor selection/type question

in ROBOTC for CORTEX & PIC

getgray

0

3031

Thu Jul 02, 2015 5:50 pm

getgray View the latest post

There are no new unread posts for this topic.   I need help with my program look for the*************** in the code Datalogging with EV3

in ROBOTC for LEGO MINDSTORMS

sawyerfs

0

3191

Fri Jun 26, 2015 6:23 pm

sawyerfs View the latest post

There are no new unread posts for this topic.   Hi, I am trying to use the vex cortex I2C port to communicate with a non-vex sensor (to be precise, a MMA8452Q accelerometer). I believe this is theoretically possible, as the cortex master firmware now supports i2c to communicate with the vex encoders. However, I could find no support as to how to use the i2c port directly in RobotC. I am looking for a function that would enable me to send a specific message, and get the slave's reply. At first sight, two function's name look promising :... Cortex generic I2C

in ROBOTC for CORTEX & PIC

mattvi

0

3122

Tue Jun 23, 2015 2:11 pm

mattvi View the latest post

There are no new unread posts for this topic.   Hello community! I found the algorithm of path finding under forum from RobotC: Azhari put it in. The code was written by Tim Friez. I modified it as I needed it. It is very easy to modify the matrix/grid and change the starting point of robot and the goal. I coded it for my LEGO NXT REM-Bot, but it works without changings in RVW. Watch the video on Youtube: 3K5Z7tmUshg Here ist the code: Hope, you have fun to try it. Bye, Sigtrygg NEW PROJECT: Path-Finding-Robot

in Robot Virtual Worlds

Sigtrygg

0

4981

Sat Jun 20, 2015 2:35 pm

Sigtrygg View the latest post

There are no new unread posts for this topic.   Passing variables through debug stream So i am attempting to pass values from the controller to the debug stream: This code is all in a loop and so it repeats every 10 seconds. but every time i do this i get Channel 2 value: 0 and Button 5D value:0 Every time even when i press 5D or move Channel 2. Any help would be appreciated. Passing variables through debug stream

in ROBOTC for CORTEX & PIC

Asim Poptani

0

2967

Sat Jun 13, 2015 3:48 am

Asim Poptani View the latest post

There are no new unread posts for this topic.   I am using RobotC 4.3 Is there a way to increase the size of the "Constant Pool"? This is a section of memory that stores all of the constants used in a RobotC program. The contents of the Constant Pool can be viewed by pressing F9 after compiling the code. The "Disassembly" will be shown and the "Constant Pool" is located immediately following the "task main()" declaration. The "Disassembly" will also show a "Constants summary" at the... Increasing the size of the Constant Pool

in ROBOTC for LEGO MINDSTORMS

jkandra

0

2737

Tue Jun 09, 2015 10:36 am

jkandra View the latest post

There are no new unread posts for this topic.   We have written a program to send a message from one NXT to another to get a sensor value. However, we are running into trouble when trying to get the value back on the first NXT who asked for the value (the other NXT should have received a number "101" to which it should send the value back). This is the code on that NXT: When we run the two programs, we know that one of the NXTs receives the "101" and checks the sensor value, displaying it on the screen. The other NXT,... Bluetooth Receiving

in ROBOTC for LEGO MINDSTORMS

smallkitten

0

2501

Mon Jun 01, 2015 8:22 pm

smallkitten View the latest post

There are no new unread posts for this topic.   This has been fixed in the upcoming release :) = Xander Attachment(s) Renaming in 4.x

in Issues and Bugs

mightor

0

3753

Mon Jun 01, 2015 3:29 am

mightor View the latest post

There are no new unread posts for this topic.   This is an open letter to all members of this site asking for helo and info. I have seen a number of videos featuring a handmade automatic pinsetter based on BRUNSWICK and AMF real pinsetters such as the A2 or 82-70/90. All fully robotized/motorized, fully functional as in the real pinsetter. The builders are not identified, nor is there a way to contact any builder. What I would like to ask is links to builders or published plans for a pinsetter built from LEGO parts, or an existing LEGO kit... lego pinsetter

in General Discussions

rtrg

0

3117

Thu May 21, 2015 11:42 am

rtrg View the latest post

There are no new unread posts for this topic.   Hello! Thank you for reading this. I'm making an labyrinth robot. I have studied a lot of this class of robots. I have a question for all the people that have worked with "micromouse". I will use homemade infrarred sensors ( IR LED + photoTransistor) but I want to know your opinion about putting the sensor in my robot a 90 degres , I mean at 0°, 90° & 180° or putting them in 45°, 90 ° & 135° ? Actually I'm adding the encoders too. But for the final desing I need to consider... What is the best position for infrarred sensors?

in General Discussions

Ryutaku

0

2965

Sun May 17, 2015 3:26 pm

Ryutaku View the latest post

There are no new unread posts for this topic.   I am using a hitecnic compas in EV3 and when I am going to compilate the program this warns problems with the library problem with library "advanced sensor"

in Third-party sensors

CyD

0

4137

Tue May 12, 2015 6:44 am

CyD View the latest post

There are no new unread posts for this topic.   Hi, Recently I have been trying different controllers for RVW. I had an Xbox controller working several weeks ago, and recently I tried plugging in a PS4 controller and trying that. The first day I tried it, (yesterday) it was working fine, all I had to do was re-configure the joystick. Today, I tried to open the Joystick Configuration, and my RVWs crashed. Whenever I try to reconfigure the joystick with it plugged in, it crashes. I can open the Controller Reconfiguration window when the... Controller Configuration Crashing RVW

in Robot Virtual Worlds

9807b

0

4858

Sat May 09, 2015 3:11 pm

9807b View the latest post

There are no new unread posts for this topic.   I'm new to Vex, but not new to ROBOTC. My first few attempts at downloading programs to the Vex were successful; however, after that, I would get a dialog asking me to select a communications port to use for the procedure. Sometimes my robot would be in the list, and sometimes the list would be empty. Either way, upon clicking the 'Okay' button in the dialog, it would simply reappear. This is troubling because it happens on any computer, with either of our robots, over either a USB or Vexnet... Communication Link Between Vex And PC Is Broken

in ROBOTC for CORTEX & PIC

Coder A

0

2933

Mon May 04, 2015 1:26 pm

Coder A View the latest post

There are no new unread posts for this topic.   I am running RobotC 4.30 on a Windows 7 PC. I have an early production EV3. I can write, download, and run programs from the PC or EV3. After I download the program to the EV3, if I set a global variable from the PC, the EV3 locks up and battery must be removed to recover. If this is a new bug and not repeatable I can post code and more details. If it is a known issue or easily repeatable I will let the professionals take it from here. Thanks for your support. RobotC 4.30 EV3 lockup

in Issues and Bugs

CARBOT

0

4297

Thu Apr 30, 2015 12:07 pm

CARBOT View the latest post

There are no new unread posts for this topic.   This is an issue from my previous topic, but I would like to open another one because I can reproduce the error now. I have three quadrature encoders plugged into the cortex, and 11 out of the 12 digital ports are being used. When I plug these quad encoders into different ports and 'open debugger manually' in robotC to view sensor values, the encoder which has a wire plugged into port 4 can have invalid values of -1, 0 or 1. Here are the steps to reproduce the error. 1. Plug the three encoders... Attachment(s) Quadrature sensor not working when plugged in cortex port 4

in ROBOTC for CORTEX & PIC

goneaswind

0

2670

Wed Apr 29, 2015 7:01 am

goneaswind View the latest post

There are no new unread posts for this topic.   Hi there, new to the board. I'm wondering if there is a RobotC equivalence to Arduino's "analogWrite()" function? The reason that I ask is because I've added a PIR sensor to the VEX PIC and wanted to set the sensor to low right after the robot has stopped moving, instead of having to put a "wait" function for it to turn off. Thanks in advance! PIR sensor

in ROBOTC for CORTEX & PIC

eibbedkcapkcab

0

2579

Mon Apr 27, 2015 10:49 pm

eibbedkcapkcab View the latest post

There are no new unread posts for this topic.   Quais são os sensores de medição de distância para arduíno existentes?Vocês podem me passar links com as informações sobre os sensores que medem distância existentes? Também quero saber sobre suas experiências com algum(ns) do(s) sensores, então se tiver, por favor relate-a tipo sobre o alcance prático e a precisão. Desde já, agradeço. Quais são os sensores de medição de distância para arduíno?

in ROBOTC for Arduino

gilmartaj

0

4631

Mon Apr 27, 2015 2:20 pm

gilmartaj View the latest post

There are no new unread posts for this topic.   Been having a miserable time with the white keys. I have followed the download/update procedures for everything that I can think of and as spelled out on the VEX update sheet. When they are plugged in, they blink blue for a moment and then nothing. What version of the VEX key update runs with which version of RobotC? Any suggestions would be much appreciated. White Keys won't connect

in ROBOTC for CORTEX & PIC

r_myers

0

2456

Tue Apr 21, 2015 8:41 pm

r_myers View the latest post

There are no new unread posts for this topic.   I have a new computer. How do I move my copy of Robotc from my old computer to my new computer. move 4.30 from old computer to new computer.

in ROBOTC for CORTEX & PIC

ronaldle

0

2340

Sat Apr 18, 2015 8:02 am

ronaldle View the latest post

There are no new unread posts for this topic.   I am trying to control 3 motors with a remote I used the optimized sample code which by itself works fine for 2 motors. (I can control robot) I tried to add a 3rd motor control via buttons 5 and 6 (From curriculum notes on robotC) I am attaching the program (The NXT says it is a "Bad Version") when I download it and try to run it? Attached program---what is wrong at the bottom please? Attachment(s) Remote control NXT

in ROBOTC for LEGO MINDSTORMS

alisbahc

0

2236

Mon Apr 13, 2015 8:07 pm

alisbahc View the latest post

There are no new unread posts for this topic.   Hello, I'm a newbie with RobotC and am interested in controlling a NXT and EV3 from a laptop and joystick at the same time (as part of the same robot). Is this possible? Thanks, Brad Controlling NXT and EV3 Simultaneously

in ROBOTC for LEGO MINDSTORMS

bradomail

0

2424

Fri Apr 03, 2015 10:14 pm

bradomail View the latest post

There are no new unread posts for this topic.   I am ready to teach my students about the light sensor and plan on using the Line runner challenge 1 with this class, as the main challenge. From what I have read, there is more that I need to teach them in order to be able to detect the lines with the light sensor and then return to the start and so forth, until the robot has reached all of the lines in the challenge. What other units do they need to know about before attempting this challenge? Thank you. Line Runner Challenge

in ROBOTC for LEGO MINDSTORMS

Korndog

0

2633

Mon Mar 30, 2015 11:47 am

Korndog View the latest post

There are no new unread posts for this topic.   Hello to all... I've been using RobotC for about a year know, and I've recently been wanting to apply image processing (e.g. object identification and/or facial recognition) using a 3rd party camera to my Vex Cortex.. I can't seem to find any support towards this idea directly through RobotC, so I downloaded a library called OpenCV, but when I tried to include and compile the files, I came up with errors of unknown commands. Is there a way to apply image processing directly through RobotC, or... Usage of image processing with 3rd party camera

in ROBOTC for CORTEX & PIC

bob10113

0

2540

Sun Mar 29, 2015 6:37 pm

bob10113 View the latest post

There are no new unread posts for this topic.   I need help figuring out how to get the acceleromiters in the controller to work. I've started a project where i use 2 motors to control the nobs on a etch-a-sketch.. I've tried to do some research on this and have not found anything that would help me. I would like to know if you need ant extra parts to control the acceleromiters built in the controller. A sample code would help a lot. How do i access acceleromiters built in the vez controller?

in Project Discussions

Sam1234

0

4094

Fri Mar 27, 2015 4:39 pm

Sam1234 View the latest post

There are no new unread posts for this topic.   Our robotc code in competition is not working sometimes when we connect to the tower is there a reason why? Autonomous Code Help

in ROBOTC for CORTEX & PIC

PatapscoPunishers

0

2956

Wed Mar 25, 2015 10:03 am

PatapscoPunishers View the latest post

Display posts from previous:  Sort by:  
Page 5 of 17 [ Search found 809 matches ]



Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.