View unanswered posts | View active topics It is currently Thu Nov 23, 2017 7:30 am




View unanswered posts

Search 
   Topic Preview  Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic.   Hi, i like to read the reflected Value and the color green. how to use different mode of color sensor (Color/Reflected)

in ROBOTC for LEGO MINDSTORMS

denist

0

3657

Wed Mar 30, 2016 12:55 pm

denist View the latest post

There are no new unread posts for this topic.   Write a program that will do the following four conditions at the same time: 1) When the bump switch is pressed, left motor turns half speed at CW. 2)When limit switch is pressed, right motor turns half speed CW. 3) When light sensor is covered, flashlight turns on. 4) Otherwise everything is off. running multiple programs simultaneously

in ROBOTC for VEX IQ

r9990

0

3290

Sat Mar 26, 2016 11:07 pm

r9990 View the latest post

There are no new unread posts for this topic.   I was working with my wife's robot IQ team using Graphical RobotC. We got the main autonomous program worked out and it works great, but the second and third ones they loaded onto the IQ brain do nothing. I see them under the menus, click to run, and nothing happens. Actually you can see that it does some processing for about 1 second then returns to the menu. They used the simple motor commands like move forward and turn... so nothing to complicated. Any ideas as to where to start tracking... programs not running

in ROBOTC for VEX IQ

n5vei

0

3287

Fri Mar 25, 2016 3:15 pm

n5vei View the latest post

There are no new unread posts for this topic.   I've created simple program to test Ev3 virtual worlds. As they said in documentation: But robot doesn't move straight. It turns... I've tried different nTurnRatios? nothing helps.. Virtual Worlds works wrong with EV3. How to move straight?

in Robot Virtual Worlds

Vario

0

3048

Sat Mar 19, 2016 5:25 pm

Vario View the latest post

There are no new unread posts for this topic.   Hi guys, I'm working on a project where I need to exchange sensor data from one NXT to another. I'm wondering if someone can point me in the right direction or link me to a tutorial to help code this? Thanks NXT Bluetooth Tutorial for RobotC

in ROBOTC for LEGO MINDSTORMS

[ ]

0

3367

Tue Mar 15, 2016 2:36 pm

[ ] View the latest post

There are no new unread posts for this topic.   Hello, I have written a function for a turn with acceleration at the start of the turn and decceleration at the end. The code is: Most of the time it is working great. But sometimes (more or less randomly) it gets stuck. It appeares as if something was wrong with the condition in while statement or the encoder is malfunctioning. The master (even if I switch the roles of master and slave) encoder/wheel gets blocked, meaning the encoder value remains the same. The other motor keeps spinning. If I... Blocked encoder

in ROBOTC for LEGO MINDSTORMS

u50cent

0

3228

Fri Mar 11, 2016 6:04 pm

u50cent View the latest post

There are no new unread posts for this topic.   I did this in LIM mode. I changed the voice to +30% pitch to sound more like MeccaNoid Notice how he looks down to find that extra fry. MeccaNoid does- Mc Donald's Comedy Sketch

in General Discussions

MeccaNoid Madness

0

1491

Thu Mar 10, 2016 3:01 pm

MeccaNoid Madness View the latest post

There are no new unread posts for this topic.   I did this in LIM mode. I changed the voice to +30% pitch to sound more like MeccaNoid. I like the G-One riddle. My niece and nephew loved this. MeccaNoid does- Kids Jokes

in General Discussions

MeccaNoid Madness

0

1409

Thu Mar 10, 2016 3:00 pm

MeccaNoid Madness View the latest post

There are no new unread posts for this topic.   I have a NXT motor hooked up to my arduino and motor shield, and can feel it vibrating as though it has power. Yet when I try to run the code I have it does nothing. Getting Nxt motor to run with arduino and motor shield

in ROBOTC for Arduino

Okurasha

0

3461

Tue Mar 08, 2016 11:37 pm

Okurasha View the latest post

There are no new unread posts for this topic.   Hello! I made all googling I could and didn't find any help... I'm using serial IR tower to programming my RCX 1.0. It's connected by RS323 to USB adapter. It's working properly with RobotC 2.03 on Win7 32bit. Now I'm trying to use it with Windows 7 or Windows 10 64-bit, but after trying to use 'Test message link' it changes states from on to off and back to on and then whole program freeze. Do you know what is the source of this? I know that USB tower is not working with 64bit systems but I... Windows 64bit and serial tower

in ROBOTC for LEGO MINDSTORMS

natoska

0

3363

Tue Mar 08, 2016 9:10 pm

natoska View the latest post

There are no new unread posts for this topic.   My friend and I started making a mini sumo bot for the NRC and we are trying to get a HiTechnic DC Motor Controller for TETRIX to become compatible with a NXT mind and we are programming with the NXT Mindstorm programming, our main problem is trying to find a way to get the motor PID that we downloaded to work on with the programming, any advice would be appreciated. connecting a nxt to a hitechnic motor controller programming

in ROBOTC for LEGO MINDSTORMS

tacobrosz89

0

3177

Wed Mar 02, 2016 12:11 pm

tacobrosz89 View the latest post

There are no new unread posts for this topic.   VEX Works Now!! I just switched out the vex keys for the third time and it works! I guess I'm just really unlucky when it come to picking vex net keys... :D :D ************************************************************************************************************************* I bet you get this a lot, but pretty much my VEX cortex won't hook up to my vex controller, when I hook up to two on a USB cable they do link up and everything works fine. But when I use the VEXnet keys, it doesn't... VEXnet Controller Not Working

in ROBOTC for CORTEX & PIC

ijsalamon

0

3144

Mon Feb 29, 2016 5:01 pm

ijsalamon View the latest post

There are no new unread posts for this topic.   Hello, I am participating in the Nothing But Net Programming skills competition, and noticed during testing that balls are launched farther when the conveyor is running in reverse. It happens consistently, but I am not sure whether or not it is an intended feature. Would this be considered a glitch, or is it a valid strategy? RVW Nothing But Net Clarification

in Robot Virtual Worlds

asciiporpoise

0

3109

Sat Feb 27, 2016 5:48 pm

asciiporpoise View the latest post

There are no new unread posts for this topic.   Hello. My team and I were wondering if there has been a new high score for the online challenge, and if there was, would it be posted on the blog? Thank you. High Scores for Nothing But Net Online Challenge

in Robot Virtual Worlds

InspectorGadget

0

3024

Sat Feb 27, 2016 12:03 am

InspectorGadget View the latest post

There are no new unread posts for this topic.   Hello, My team and I were working on the VEX Nothing But Net (Programming Skills) Online Challenge, and as we were trying to use preloads to score, we realized that we could not click at the exact moment a ball becomes available. Is it permitted for us to run an automatic clicker for the preloads section to reduce the time wasted as we try to score these balls? If so, should we submit the auto clicker with our program and include instructions? Thank you, 979A Auto clicker for Preloads VEX Programming Skills

in Robot Virtual Worlds

InspectorGadget

0

2826

Fri Feb 26, 2016 11:58 pm

InspectorGadget View the latest post

There are no new unread posts for this topic.   Is there a way to apply code do that a potentiometer controls the power the motor receives. If so please help on how to do so. Potentiometer to control Motor

in ROBOTC for VEX IQ

jbonsall

0

3220

Mon Feb 22, 2016 2:44 pm

jbonsall View the latest post

There are no new unread posts for this topic.   We recently noticed our color sensors are mixing black and white color and reads the mix as "blue". This happens when our robot "bounces" of a white line on a black course. The robot is also looking for "Blue" because blue lines indicate the robot has reached a parking lot and needs to park in the parking lot. But when the robot is bouncing off the white line there are many times when the color sensor is half on the white line and half on the black line, at these... Color sensor mixing black and white and reads blue

in ROBOTC for LEGO MINDSTORMS

profgass

0

3200

Sat Feb 20, 2016 2:13 pm

profgass View the latest post

There are no new unread posts for this topic.   We are having trouble with solving this problem and could use some help. In this task we are to continuously go around an object as a sentry. If we come to an object that is observed using our ultrasonic sensor, we are to stop until it is removed. Once removed, we are supposed to continue our "sentry duty". Our robot will stop, but only after it makes a turn. If an object is placed in the way during a "straight" portion, it will not stop. If it is placed in front of the... Simulation Sentry II Problems

in ROBOTC for CORTEX & PIC

droberts6262

0

3519

Thu Feb 18, 2016 5:42 pm

droberts6262 View the latest post

There are no new unread posts for this topic.   I have problem with implementing attached C code in robotC. I tested C code in CodeBlocks and works perfectly. Thanks for help. Attachment(s) Implementing C code in RobotC

in ROBOTC for LEGO MINDSTORMS

arozma

0

3018

Thu Feb 18, 2016 3:21 pm

arozma View the latest post

There are no new unread posts for this topic.   Hey guys, I'm having a problem with my code for my POE marble sorter. It runs but after I press my bump switch the motor with an encoder on it only moves in one direction and the servo to feed the marbles into the cups goes back and forth. When I hit the button, it runs, but it starts my hopper motor and only moves one direction, meanwhile the servo keeps moving to 0 and -63. I noticed that the quadrature encoder I have on the hopper motor so I can figure out where it is, resets to 0 every time... POE Marble Sorter Code is not working

in ROBOTC for VEX IQ

coltonh

0

5144

Wed Feb 10, 2016 8:37 pm

coltonh View the latest post

There are no new unread posts for this topic.   Cable Winding Mechanism A telecommunications contractor need you team design a device that can accurately wind up a specific length of cable. The device must be able to wind a specific length consistently. The device must also be able to be started and stopped(emergency) by using a switch. I want to share my first project that I did for my cable winding mechanism This machine will go down or up by press bump1 or bump2, also it can change the directions when I press different bumps Sonar1... Perfect Cable Winding Mechanism Code Script

in ROBOTC for LEGO MINDSTORMS

SWEETMUSK

0

2503

Sat Feb 06, 2016 12:22 am

SWEETMUSK View the latest post

There are no new unread posts for this topic.   I remember reading that it was not supported a while back, I wanted to know if there were any updates, and where I can find documentation on it if it does support. Also where can I find what robotC supports for EV3 and what it does not. Thanks. Does RobotC support EV3 and TETRIX motors/servos.

in ROBOTC for LEGO MINDSTORMS

jcs0190

0

1599

Tue Feb 02, 2016 1:13 pm

jcs0190 View the latest post

There are no new unread posts for this topic.   It's almost as funny as the Car-Drive thru prank. FUNNY - The Pickup Artist

in Off-Topic

MeccaNoid Madness

0

2396

Mon Feb 01, 2016 8:54 pm

MeccaNoid Madness View the latest post

There are no new unread posts for this topic.   I did this in LIM mode, this was longer then 2 min., so I had to string 2 LIMs in the video. I changed the voice to +30% pitch to sound more like MeccaNoid. This was fun for me, I love Star Wars. ~~~~~~ SPOILER - if you did not see the movie, click on this ~~~~~~ MeccaNoid does- Star Wars The Force Awakens Game

in General Discussions

MeccaNoid Madness

0

1319

Mon Feb 01, 2016 12:20 pm

MeccaNoid Madness View the latest post

There are no new unread posts for this topic.   I have an NXT robot that I am trying to connect to robotC but even after updating my drivers, link, and other different things like a new cord, it shows up in device manager, but I don't understand why this isn't working and showing up in the robotC program. NXT Robot not connecting

in ROBOTC for LEGO MINDSTORMS

xdnewlun

0

1436

Thu Jan 28, 2016 6:32 pm

xdnewlun View the latest post

There are no new unread posts for this topic.   I am totally new to this and have looked in the help files, but have either overlooked it or just cannot find it. In RobotC4.x, how do I designate the slot to load the program in? Thanks for any help. Bill R. VEX IQ Programming slot

in ROBOTC for VEX IQ

n5vei

0

3207

Wed Jan 27, 2016 10:40 am

n5vei View the latest post

There are no new unread posts for this topic.   Hello Forumers - I have a 12VDC motor with "built-in" encoder. The motor has a 2 wire connection, and runs both directions fine. The encoder also has a 2 wire connection, but I have no idea how to wire it. It probably requires some external circuit, but the closest example found uses a 3 wire connection to the encoder. I have even tried using the case as ground to make a "3rd" connection. The motor didn't come with any schematics or specifications. Searches have drawn a... Attachment(s) Shaft encoder wiring - 2 wire encoder

in Project Discussions

itsallgood

0

3539

Tue Jan 26, 2016 3:00 am

itsallgood View the latest post

There are no new unread posts for this topic.   I've have to navigate through this board using my ev3. I have attached the file of the picture. The white block is my ev3 robot. I need to turn and scoop up the gold ball which is located in the slot beside the robot on the right. Then I have to follow path A and drop the ball in the box over the ramp. After that the robot has to come back down the ramp and finish at the finish line for A/C. What I need to use is the touch sensor and gyro sensor and I haven't been taught anything and was told... Attachment(s) I need help with coding my EV3! (ANYONE)

in ROBOTC for LEGO MINDSTORMS

Musaraki

0

1781

Sun Jan 24, 2016 4:32 pm

Musaraki View the latest post

There are no new unread posts for this topic.   I am doing a project for my high school engineering class and im having a problem figuring out the programing. Ive never done any programing before and could really use some help. We are trying to get two sonars to track when someone walks from left to right to count up one on our lcd screen and when someone walks from right to left to count down one on the lcd screen. below i attached an image of what our current program and prototpe look like .Any advice could be a huge help at this point,... Attachment(s) person tracker

in FTC Programming

confused_student

0

2586

Thu Jan 21, 2016 5:49 pm

confused_student View the latest post

There are no new unread posts for this topic.   Hi, in my POE class im trying to do the start and finish line project. im trying to write a code so that when the LED is on start the timer and while the bump or line follower (what we are using to mark the time) is >1 mark the timer. and if the bump is <1 continue. all and all can someone guide me through this. plz and thx How to write a program to start and stop a timer with LEDs

in Project Discussions

POEchill

0

2951

Wed Jan 20, 2016 3:50 pm

POEchill View the latest post

There are no new unread posts for this topic.   I selected the Autopilot Bot to use (that is the robot we built in class), and I was working on the 50m challenge. I can get IQ Clawbot to respond to the code, but the Autopilot Bot does not. It continues on past and off the table. I check the Motor and sensors setting. everything seems to be in order..... any ideas? VEX IQ Challenge Pack - Encoders

in ROBOTC for VEX IQ

DRBandy

0

3302

Tue Jan 19, 2016 12:47 pm

DRBandy View the latest post

There are no new unread posts for this topic.   Hi! i need help quickly. So I've created a robot that drives but the turning didn't work. So this is my code and it requires two touch sensors to turn. One for left turn and the other one for the right turn. The motorA on the robot is turned sideways so I just need to control how many degrees must it go in both directions. I can't try my code so I would really appreciate it if you could tell me if this code would work? If not could you help me? Thank you all! Attachment(s) Robot turning with wheel at the back

in ROBOTC for LEGO MINDSTORMS

hehahe

0

4063

Tue Jan 05, 2016 10:24 am

hehahe View the latest post

There are no new unread posts for this topic.   Hello everyone ! I try to make communicate a PC with Bluetooth and a EV3. I read the posts concerning BT written in 2014 saying that it wasn't possible tu use it on a ev3. I work with Robotc 4.5 and this is an example called Mailboxdemo. I can communicate in direct command ( motors go on and stop when i command it under realterm). I try to send a message in bluetooth with the format needed bbbbmmmmttssllaaaaa...LLLLppp... and adapt the mailbox demo code but without success. Has anybody try such... Communication between a PC and EV3 with Bluetooth

in ROBOTC for LEGO MINDSTORMS

mobytango

0

4318

Tue Dec 22, 2015 10:48 am

mobytango View the latest post

There are no new unread posts for this topic.   Hello everyone, Not sure what topic this came under so put it in here as my robot uses Cortex. I have been having some trouble with my line following code which works perfectly on another robot of the same build so investigated why it was not working. When I plugged my robot into my computer and display the live feed of my sensor values, I noticed one was always lower than the other, even up to 1000 in difference when trying to read a black line. So, my question is what do you think is causing... Broken Line Tracker

in ROBOTC for CORTEX & PIC

RWelsh

0

4093

Wed Dec 02, 2015 4:36 pm

RWelsh View the latest post

There are no new unread posts for this topic.   Chance twist on 90/180/360 sensor accelerometer hitechnic? If so, write a sample program for engines and stop at the turn of 90 degrees. Chance of rotation sensor accel

in ROBOTC for LEGO MINDSTORMS

bonny

0

4054

Sun Nov 22, 2015 12:23 pm

bonny View the latest post

There are no new unread posts for this topic.   I am attempting to pass an array of a struct to a function and assigning a variable to store it. However this has not been working (the secondary array struct is empty). Any help explaining this would be greatly appreciated. Passing arrays in robotc 3.65

in ROBOTC for CORTEX & PIC

Asim Poptani

0

4121

Sat Nov 21, 2015 2:31 am

Asim Poptani View the latest post

There are no new unread posts for this topic.   Has anyone created a Robot Virtual World for the First Lego League 2015-16 Trash Challenge? Virtual World for First LEGO League 2015-16

in ROBOTC for LEGO MINDSTORMS

RKFLL

0

4463

Thu Nov 19, 2015 7:31 pm

RKFLL View the latest post

There are no new unread posts for this topic.   Hi, I have a NXT Brick that I have not used for RobotC yet. I plugged the Nxt in and it told me that I needed to update the firmware first, so I did, and the NXT went into firmware mode. I am not sure what caused this, but I think it has something to do with the drivers. If you guys have any ideas I'm all ears! Firmware not working correctly

in ROBOTC for LEGO MINDSTORMS

EaglemanNXT01

0

4235

Tue Nov 17, 2015 8:44 pm

EaglemanNXT01 View the latest post

There are no new unread posts for this topic.   Trying to write a line following code with obstacle avoidance, navigate circumference of obstacle, then refind line and continue on. I am a beginner. I am having problems with 2 sensors wanting to acquire control of motors. I included my attempt at writing the code. The original had 3 separate tasks, one for each sensor. I kept trying to tweak it and this is what it looks like now. It's for school project. Any help would be greatly appreciated! #define EYE SENSOR_3 #define LEFT OUT_C #define... issues using multiple sensors-beginner

in Project Discussions

roper710

0

5375

Sat Nov 14, 2015 8:26 pm

roper710 View the latest post

There are no new unread posts for this topic.   What i mean by this is i would like to use the PID value or change in value in my code to start other code. I was wandering if there was a way to retrieve the value of the PID and use it as a variable of sorts to be able to then test in say a while loop and then be able to start other code when the PID reaches a certain value or group of values. thanks for the help :) How To? Use PID as a value in your code.

in ROBOTC for LEGO MINDSTORMS

Lando

0

4295

Sun Nov 08, 2015 6:09 pm

Lando View the latest post

There are no new unread posts for this topic.   I have been working on an EV3 sensor built from a Arduino mini and LSM9DS0 sensor for the last couple of months. xgApGJCw-2A The sensor can feed the EV3 with: Pitch & Roll, Heading, Gyro rate,accelerometer and magnetometer. EV3 Sensor.tiff A special block is imported into the EV3 software and can be used like any other sensor. IMG_1720.JPG IMG_1721.JPG The Circuit board has been designed to attached to Lego Technic Pegs. Attachment(s) EV3 Arduino Sensor Shield

in Third-party sensors

Gadgeering

0

6408

Sun Nov 08, 2015 3:45 am

Gadgeering View the latest post

There are no new unread posts for this topic.   Hi therobotmaster. Your problem is just a simple maths error. In simple speak, the compass sensor reads values in a circle. This circle ending at 359 degrees. But because its a circle, each value has another value that is the same point. e.g. 20 degrees is the same as 380 degrees, because its one entire loop of the circle. The problem with this is that 380 is outside the range of values the compass sensor can process. Luckily there is a simple solution. Because the circle loops like I described... HiTechnic Compass Sensor value out of limits

in ROBOTC for LEGO MINDSTORMS

KingofKool

0

4442

Thu Nov 05, 2015 8:28 pm

KingofKool View the latest post

There are no new unread posts for this topic.   I am having an issue using virtual world part of robotc so ill open up the program open my program make sure there are no errors then go to open it up so i can drive around but then the program completely crashes and closes do you have any ideas on what i might be doing wrong or how to fix it RobotC Virtual World Error

in ROBOTC Forums Suggestions/Comments

jay-u-a

0

6599

Thu Nov 05, 2015 11:55 am

jay-u-a View the latest post

There are no new unread posts for this topic.   Hello, we are new to ROBOTC and writing our first program for Bankshot. Our problem is after we run our program, our robot is at the top of the ramp. As soon as the program ends, the robot rolls backwards off the ramp instead of staying put. When we drive with the remote control, the robot remains on the ramp when we stop. Is there a line of code we need to include to lock the robot in place? I tried Stop All Motors but it did not work. Thank you for your help! Robot rolling backwards

in ROBOTC for VEX IQ

dtabe

0

6277

Wed Nov 04, 2015 9:46 pm

dtabe View the latest post

There are no new unread posts for this topic.   Hi All, The Robot uses an EV3 Programmable Brick to control 3x Large NXT Servo Motors and a Medium EV3 Servo Motor. The Medium Servo Motor Rotates the Monkey's Arms. Each of the Monkey's Hands is opened and close with a Large Servo Motor. The third Large Servo Motor animates the Monkey's Tail. The Monkey is programmed in RobotC which is available at . 4XYM04InGaw Full project details including CAD Building Instructions and "C" Code will be available shortly on my blog, at Attachment(s) Just Monkeying Around...

in ROBOTC for LEGO MINDSTORMS

sparramc

0

4889

Fri Oct 23, 2015 11:06 am

sparramc View the latest post

There are no new unread posts for this topic.   Hello, I am trying to make a program what can make a screenshot of the NXT screen. The idea is to read pixel by pixel from the screen with the getPixel(x,y) function. storing it in a file and read it when needed. Emulated on the PC it works (stored the data in an array in stead of a file). The getPixel function on the NXT has weird behavour. This code generates 4 exceptions when running. Sometimes the NXT goes to clicking mode. Same results with robotC 4.5 and 4.3 Any ideas? Thanks getpixel(x,y) function error

in ROBOTC for LEGO MINDSTORMS

nxt

0

4700

Mon Oct 05, 2015 5:56 pm

nxt View the latest post

There are no new unread posts for this topic.   I have had an old Vex PIC system for several years now along with the old orange style of programming hardware kit. However, I have never been successful in getting programming software to work due to issues with licenses. When I saw there was a free version of RobotC 3.63 for Vex PIC available, I thought I would finally be able to put the sensory hardware I have to use. The installation worked on Windows 10 without any problems. However, I could not establish a link with the PIC controller... Problems connecting PIC to RobotC

in ROBOTC for CORTEX & PIC

B.E.M.

0

5203

Sat Oct 03, 2015 2:30 pm

B.E.M. View the latest post

There are no new unread posts for this topic.   The documentation for the rand() function (RobotC 4.X for LEGO Documentation > General C Programming > Math) here: says: A typical way to generate pseudo-random numbers in a determined range using rand is to use the modulo of the returned value by the range span and add the initial value of the range: ( value % 100 ) is in the range 0 to 99 ( value % 100 + 1 ) is in the range 1 to 100 ( value % 30 + 1985 ) is in the range 1985 to 2014 and provides the sample code: The rand() function does... rand() function documentation, RobotC 4.X

in Issues and Bugs

jaiclinm

0

6741

Thu Oct 01, 2015 10:38 pm

jaiclinm View the latest post

There are no new unread posts for this topic.   Hello all, I'm new to RobotC and robotics in general, but I've done a little bit of programming in the past for fun. Anyways, I don't like the restrictions for ordinary arrays, so I tried making my own linked list data structure. The problem is, even when I only make one node, it corrupts the firmware apparently because it makes the program crash and I can only seem to fix it by re-downloading the firmware in the Robot program. Why is this happening? Is it my code? (I'm not a very good... Downloading source to robot corrupts firmware?

in ROBOTC for CORTEX & PIC

tyridge77

0

4788

Thu Oct 01, 2015 10:49 am

tyridge77 View the latest post

There are no new unread posts for this topic.   Hi, I am trying to establish a Bluetooth connection with my EV3 with RobotC 4.50v. I have a built-in Bluetooth device Motorola 2.1 + EDR running with a Windows 7 64 bits OS. The pairing is successful, the COM port 3 is created, actually we have a EV3 Bluetooth logging software which uses the COM port to get measures from EV3 sensors and works perfectly. The problem arises when we try to look for the EV3 brick in Communication Link Setup by Bluetooth but the search does not retrieve any device,... Connection problem with built-in Bluetoot, RobotC and EV3

in Issues and Bugs

iscjnavarro

0

6563

Mon Sep 28, 2015 11:16 am

iscjnavarro View the latest post

Display posts from previous:  Sort by:  
Page 4 of 17 [ Search found 809 matches ]



Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.